CVE-2026-46396
CVE-2026-46396 · HAX CMS has a stored XSS via <iframe> that allows access to sensitive client-side data and account takeover
This page contains facts from public vulnerability sources. Check the original advisory before updating.
HAX CMS helps manage microsite universe with PHP or NodeJs backends. A stored cross-site scripting (XSS) vulnerability exists in versions prior to 26.0.0 due to improper sanitization of `<iframe>` elements. The application allows `javascript:` URIs in the `src` attribute, which are executed when a malicious page is viewed. This enables attackers to execute arbitrary JavaScript in the context of the victim’s browser and access sensitive data exposed to client-side scripts. Version 26.0.0 fixes the issue.
CVSS 9.3 · Critical · EPSS 0.2% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
haxcms-nodejs
- Versions
- < 26.0.0: Affected
No fix published
video-player
- Versions
- < 26.0.0: Affected
No fix published
iframe-loader
- Versions
- < 26.0.0: Affected
No fix published
@haxtheweb/haxcms-nodejs npm
- Affected ranges
- SEMVER: < 26.0.0
Update to 26.0.0
@haxtheweb/video-player npm
- Affected ranges
- SEMVER: < 26.0.0
Update to 26.0.0
@haxtheweb/iframe-loader npm
- Affected ranges
- SEMVER: < 26.0.0
Update to 26.0.0