p PatchFirst

CVE-2026-47670

CVE-2026-47670 · DbGate Vulnerable to Authenticated Remote Code Execution via loadReader functionName code injection

This page contains facts from public vulnerability sources. Check the original advisory before updating.

DbGate is cross-platform database manager. Versions 7.1.8 and prior are vulnerable to authenticated Remote Code Execution (RCE). Any user with valid DbGate credentials can execute arbitrary OS commands as root by exploiting an unsanitized `functionName` parameter in the `/runners/load-reader` endpoint. The `require = null` mitigation is trivially bypassed via dynamic `import()`. Version 7.1.9 contains a patch.

CVSS 9.4 · Critical · EPSS 1.8% · Public exploit · Fix available

Published
Updated

Stack: node

Affected products and versions

  • dbgate

    Versions
    • < 7.1.9: Affected

    No fix published

  • dbgate-api npm

    Affected ranges
    • SEMVER: < 7.1.9

    Update to 7.1.9

Original sources

Check your server →