p PatchFirst

PatchFirst · Latest vulnerabilities

dbgate-api vulnerabilities

Vulnerabilities published for dbgate-api in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 2

  1. CVE-2026-47670

    Critical · CVSS 9.4EPSS 1.76%Public exploitFix available

    DbGate Vulnerable to Authenticated Remote Code Execution via loadReader functionName code injection

    DbGate is cross-platform database manager. Versions 7.1.8 and prior are vulnerable to authenticated Remote Code Execution (RCE). Any user with valid DbGate credentials can execute arbitrary OS commands as root by exploiting an unsanitized `functionName` parameter in the `/runners/load-reader` endpoint. The `require = null` mitigation is trivially bypassed via dynamic `import()`. Version 7.1.9 contains a patch.

    • Update to 7.1.9
    Published Updated
  2. CVE-2026-48017

    High · CVSS 8.8EPSS 0.51%Fix available

    DbGate: Remote Code Execution via functionName injection in loadReader endpoint

    DbGate is cross-platform database manager. In versions 7.1.8 and prior, the POST /runners/load-reader endpoint in DbGate accepts a functionName parameter that is directly interpolated into a JavaScript code template without any sanitization or validation. An authenticated user (with basic access, no special permissions required) can inject arbitrary JavaScript code that executes on the server with full process privileges, bypassing the require=null sandbox restriction. An authenticated user with basic access (no admin role, no run-shell-script permission required) can: execute arbitrary OS commands on the DbGate server with the privileges of

    • Update to 7.1.9
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →