CVE-2026-50131
CVE-2026-50131 · Fedify has an incomplete SSRF mitigation after GHSA-p9cg-vqcc-grcx: validatePublicUrl allows special-use IPv4 ranges
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Fedify is a TypeScript library for building federated server apps powered by ActivityPub. Fedify previously addressed SSRF/internal network access in GHSA-p9cg-vqcc-grcx by adding public URL validation before runtime document and media fetching. However, the IPv4 validation logic present starting in version 0.11.2 and prior to versions 1.9.12, 1.10.11, 2.0.19, 2.1.15, and 2.2.4 appears incomplete. The `validatePublicUrl()` protection relies on `isValidPublicIPv4Address()` to reject non-public IPv4 destinations. The function blocks common private and local ranges such as `10.0.0.0/8`, `127.0.0.0/8`, `169.254.0.0/16`, `172.16.0.0/12`, and `192.168.0.0/16`, but it still treats several special-use, reserved, multicast, benchmarking, and carrier-grade NAT IPv4 ranges as valid public destinations. Because this validation is used as an SSRF defense before outbound fetches, this appears to be an incomplete mitigation or bypass class for the previous SSRF issue. Versions 1.9.12, 1.10.11, 2.0.19, 2.1.15, and 2.2.4 contain an updated patch.
CVSS 8.6 · High · EPSS 0.4% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
fedify
- Versions
- >= 0.11.2, < 1.9.12: Affected
- >= 1.10.0, < 1.10.11: Affected
- >= 2.0.0, < 2.0.19: Affected
- >= 2.1.0, < 2.1.15: Affected
- >= 2.2.0, < 2.2.4: Affected
No fix published
vocab-runtime
- Versions
- < 2.0.19: Affected
- >= 2.1.0, < 2.1.15: Affected
- >= 2.2.0, < 2.2.4: Affected
No fix published
@fedify/fedify npm
- Affected ranges
- SEMVER: ≥ 0.11.2, < 1.9.12
Update to 1.9.12
@fedify/fedify npm
- Affected ranges
- SEMVER: ≥ 1.10.0, < 1.10.11
Update to 1.10.11
@fedify/fedify npm
- Affected ranges
- SEMVER: ≥ 2.0.0, < 2.0.19
Update to 2.0.19
@fedify/fedify npm
- Affected ranges
- SEMVER: ≥ 2.1.0, < 2.1.15
Update to 2.1.15
@fedify/fedify npm
- Affected ranges
- SEMVER: ≥ 2.2.0, < 2.2.4
Update to 2.2.4
@fedify/vocab-runtime npm
- Affected ranges
- SEMVER: < 2.0.19
Update to 2.0.19
@fedify/vocab-runtime npm
- Affected ranges
- SEMVER: ≥ 2.1.0, < 2.1.15
Update to 2.1.15
@fedify/vocab-runtime npm
- Affected ranges
- SEMVER: ≥ 2.2.0, < 2.2.4
Update to 2.2.4