p PatchFirst

PatchFirst · Latest vulnerabilities

@fedify/vocab-runtime vulnerabilities

Vulnerabilities published for @fedify/vocab-runtime in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 2

  1. CVE-2026-50131

    High · CVSS 8.6EPSS 0.35%Fix available

    Fedify has an incomplete SSRF mitigation after GHSA-p9cg-vqcc-grcx: validatePublicUrl allows special-use IPv4 ranges

    Fedify is a TypeScript library for building federated server apps powered by ActivityPub. Fedify previously addressed SSRF/internal network access in GHSA-p9cg-vqcc-grcx by adding public URL validation before runtime document and media fetching. However, the IPv4 validation logic present starting in version 0.11.2 and prior to versions 1.9.12, 1.10.11, 2.0.19, 2.1.15, and 2.2.4 appears incomplete. The `validatePublicUrl()` protection relies on `isValidPublicIPv4Address()` to reject non-public IPv4 destinations. The function blocks common private and local ranges such as `10.0.0.0/8`, `127.0.0.0/8`, `169.254.0.0/16`, `172.16.0.0/12`, and `192.

    • Update to 2.0.19
    • Update to 2.1.15
    • Update to 2.2.4
    Published Updated
  2. CVE-2026-34148

    High · CVSS 7.5EPSS 0.55%Fix available

    Fedify affected by resource exhaustion caused by unbounded redirect following during remote key/document resolution

    Fedify is a TypeScript library for building federated server apps powered by ActivityPub. Prior to 1.9.6, 1.10.5, 2.0.8, and 2.1.1, @fedify/fedify follows HTTP redirects recursively in its remote document loader and authenticated document loader without enforcing a maximum redirect count or visited-URL loop detection. An attacker who controls a remote ActivityPub key or actor URL can force a server using Fedify to make repeated outbound requests from a single inbound request, leading to resource consumption and denial of service. This vulnerability is fixed in 1.9.6, 1.10.5, 2.0.8, and 2.1.1.

    • Update to 2.0.8
    • Update to 2.1.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →