p PatchFirst

CVE-2026-5389

CVE-2026-5389 · justhtml before 1.13.0 XSS via code fence breakout

This page contains facts from public vulnerability sources. Check the original advisory before updating.

justhtml versions before 1.13.0 contain a cross-site scripting vulnerability in the to_markdown() function when serializing attacker-controlled pre content. Attackers can place backticks inside sanitized pre elements to break out of fixed-length code fences, allowing raw HTML to execute when the generated Markdown is rendered by CommonMark or GFM-style renderers.

CVSS 5.1 · Medium · EPSS 0.2% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • justhtml

    Versions
    • ≥ 0, < 1.13.0: Affected (semver)
    • 1.13.0: Not affected (semver)

    Update to 1.13.0

  • justhtml PyPI

    Versions
    • 0.1.0
    • 0.10.0
    • 0.11.0
    • 0.12.0
    • 0.13.0
    • 0.13.1
    • 0.14.0
    • 0.15.0
    • 0.16.0
    • 0.17.0
    • 0.18.0
    • 0.19.0
    • 0.2.0
    • 0.20.0
    • 0.21.0
    • 0.22.0
    • 0.23.0
    • 0.24.0
    • 0.25.0
    • 0.26.0
    • 0.27.0
    • 0.28.0
    • 0.29.0
    • 0.3.0
    • 0.30.0
    • 0.31.0
    • 0.32.0
    • 0.33.0
    • 0.34.0
    • 0.35.0
    • 0.36.0
    • 0.37.0
    • 0.38.0
    • 0.39.0
    • 0.4.0
    • 0.40.0
    • 0.5.0
    • 0.5.1
    • 0.5.2
    • 0.6.0
    • 0.7.0
    • 0.8.0
    • 0.9.0
    • 1.0.0
    • 1.1.0
    • 1.10.0
    • 1.11.0
    • 1.12.0
    • 1.2.0
    • 1.3.0
    • 1.4.0
    • 1.5.0
    • 1.6.0
    • 1.7.0
    • 1.8.0
    • 1.9.0
    • 1.9.1
    Affected ranges
    • ECOSYSTEM: < 1.13.0

    Update to 1.13.0

Original sources

Check your server →