CVE-2026-55604
CVE-2026-55604 · @arikusi/deepseek-mcp-server has an Authorization Bypass Through User-Controlled Key
This page contains facts from public vulnerability sources. Check the original advisory before updating.
DeepSeek MCP Server is an MCP server for DeepSeek V4. Starting in version 1.4.2 and prior to version 1.7.0, the process-global `SessionStore` accepts caller-supplied `session_id` values without binding them to any authenticated principal or transport session. An attacker can enumerate active session IDs via `deepseek_sessions`, then reuse a victim-controlled `session_id` in `deepseek_chat` to retrieve and continue the victim's conversation context. Version 1.7.0 contains a patch.
CVSS 8.6 · High · EPSS 0.4% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
deepseek-mcp-server
- Versions
- >= 1.4.2, < 1.7.0: Affected
No fix published
@arikusi/deepseek-mcp-server npm
- Affected ranges
- SEMVER: ≥ 1.4.2, < 1.7.0
Update to 1.7.0