p PatchFirst

PatchFirst · Latest vulnerabilities

@arikusi/deepseek-mcp-server vulnerabilities

Vulnerabilities published for @arikusi/deepseek-mcp-server in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 2

  1. CVE-2026-55604

    High · CVSS 8.6EPSS 0.37%Fix available

    @arikusi/deepseek-mcp-server has an Authorization Bypass Through User-Controlled Key

    DeepSeek MCP Server is an MCP server for DeepSeek V4. Starting in version 1.4.2 and prior to version 1.7.0, the process-global `SessionStore` accepts caller-supplied `session_id` values without binding them to any authenticated principal or transport session. An attacker can enumerate active session IDs via `deepseek_sessions`, then reuse a victim-controlled `session_id` in `deepseek_chat` to retrieve and continue the victim's conversation context. Version 1.7.0 contains a patch.

    • Update to 1.7.0
    Published Updated
  2. CVE-2026-55605

    Medium · CVSS 5.3EPSS 0.52%Fix available

    @arikusi/deepseek-mcp-server Missing Authentication on Self-Hosted HTTP MCP Endpoint

    DeepSeek MCP Server is an MCP server for DeepSeek V4. Starting in version 1.4.2 and prior to version 1.8.0, the self-hosted HTTP transport of `@arikusi/deepseek-mcp-server` exposes `POST /mcp` without any authentication: `createMcpExpressApp` is called without an `authProvider` and no middleware guards the route, so any network-reachable client can issue an unauthenticated `initialize` request and obtain a valid MCP session identifier. In reproduced testing against commit `5e1302171e99`, an unauthenticated client was able to initialize a session, enumerate tools, and invoke the local `deepseek_sessions` tool with no credentials. The same unau

    • Update to 1.8.0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →