CVE-2026-59942
CVE-2026-59942 · Dompdf: Denial of Service (DoS) via Resource Exhaustion using Oversized Image Bitmaps
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Dompdf is an HTML to PDF converter for PHP. Versions 3.15 and prior are vulnerable to a Denial of Service (DoS) attack via resource exhaustion. An attacker can crash the PHP process by providing a specially crafted HTML document containing a single image with massive dimensions (e.g., 30,000x30,000 pixels). While Dompdf implements internal checks to validate image dimensions, these can be bypassed by using a high-entropy image (such as random noise) encoded in Base64 and wrapped in specific CSS containers. The vulnerability exists because the dimension validation happens early, but the resource allocation for calculating the object's bounding box and internal buffers during the rendering phase does not strictly limit the cumulative CPU time or memory usage for a single object that has passed the initial check. An unauthenticated remote attacker can cause a complete Denial of Service on the web server by submitting a crafted HTML string. This affects any application that allows users to provide HTML content or URLs that are subsequently converted to PDF using Dompdf. This issue has been fixed in version 3.16.
CVSS 6.3 · Medium · EPSS 0.9% · Fix available
- Published
- Updated
Affected products and versions
dompdf
- Versions
- < 3.1.6: Affected
No fix published
php-dompdf Debian:12
- Versions
- 2.0.3+dfsg-1
- 2.0.3+dfsg-1+deb12u1
- 2.0.3+dfsg-2
- 2.0.3+dfsg-3
- 2.0.3+dfsg-4
- 2.0.4+dfsg-1
- 2.0.4+dfsg-2
- 2.0.7+dfsg-1
- 3.0.0+dfsg-1
- 3.0.0+dfsg-2
- 3.0.1+dfsg-1
- 3.0.2+dfsg-1
- 3.1.0+dfsg-1
- 3.1.4+dfsg-1
- 3.1.4+dfsg-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
dompdf/dompdf Packagist
- Versions
- v0.6.0
- v0.6.1
- v0.6.2
- v0.7.0
- v0.7.0-beta
- v0.7.0-beta2
- v0.7.0-beta3
- v0.8.0
- v0.8.1
- v0.8.2
- v0.8.3
- v0.8.4
- v0.8.5
- v0.8.6
- v1.0.0
- v1.0.1
- v1.0.2
- v1.1.0
- v1.1.1
- v1.2.0
- v1.2.1
- v1.2.2
- v2.0.0
- v2.0.1
- v2.0.2
- v2.0.3
- v2.0.4
- v2.0.5
- v2.0.7
- v2.0.8
- v3.0.0
- v3.0.1
- v3.0.2
- v3.1.0
- v3.1.1
- v3.1.2
- v3.1.3
- v3.1.4
- v3.1.5
- Affected ranges
- ECOSYSTEM: < 3.1.6
Update to 3.1.6
php-dompdf Ubuntu:Pro:16.04:LTS
- Versions
- 0.6.1+dfsg-2
- 0.6.1+dfsg-2build1
- 0.6.1+dfsg-2ubuntu1
- 0.6.1+dfsg-2ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
php-dompdf Ubuntu:Pro:18.04:LTS
- Versions
- 0.6.2+dfsg-3
- 0.6.2+dfsg-3ubuntu0.18.04.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
php-dompdf Ubuntu:20.04:LTS
- Versions
- 0.6.2+dfsg-3
- 0.6.2+dfsg-3ubuntu0.20.04.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
php-dompdf Ubuntu:22.04:LTS
- Versions
- 0.6.2+dfsg-3.1
- 0.6.2+dfsg-3.1ubuntu0.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://github.com/dompdf/dompdf/security/advisories/GHSA-f5gf-2cj8-52g2
- https://github.com/dompdf/dompdf/commit/7c65e7bbeccf146b2409740405af73949ad129d0
- https://github.com/dompdf/dompdf/commit/89164eaabe0bb50c462f0b24f740044ba5fb0f99
- https://github.com/dompdf/dompdf/releases/tag/v3.1.6
- https://nvd.nist.gov/vuln/detail/CVE-2026-59942