CVE-2026-77088
CVE-2026-77088 · justhtml 0.9.0 through 1.21.0 Cross-Site Scripting via code-span
This page contains facts from public vulnerability sources. Check the original advisory before updating.
justhtml versions 0.9.0 through 1.21.0 contain a cross-site scripting vulnerability in to_markdown() where inline code spans fail to account for blank lines as block boundaries. Attackers can inject blank lines into code or pre element text to break the inline span, causing sanitized HTML to be emitted unescaped and re-parsed as live Markdown by compliant renderers.
CVSS 5.3 · Medium · EPSS 0.3% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
justhtml
- Versions
- ≥ 0.9.0, ≤ 1.21.0: Affected (semver)
No fix published
justhtml PyPI
- Versions
- 0.10.0
- 0.11.0
- 0.12.0
- 0.13.0
- 0.13.1
- 0.14.0
- 0.15.0
- 0.16.0
- 0.17.0
- 0.18.0
- 0.19.0
- 0.20.0
- 0.21.0
- 0.22.0
- 0.23.0
- 0.24.0
- 0.25.0
- 0.26.0
- 0.27.0
- 0.28.0
- 0.29.0
- 0.30.0
- 0.31.0
- 0.32.0
- 0.33.0
- 0.34.0
- 0.35.0
- 0.36.0
- 0.37.0
- 0.38.0
- 0.39.0
- 0.40.0
- 0.9.0
- 1.0.0
- 1.1.0
- 1.10.0
- 1.11.0
- 1.12.0
- 1.13.0
- 1.14.0
- 1.15.0
- 1.16.0
- 1.17.0
- 1.18.0
- 1.19.0
- 1.2.0
- 1.20.0
- 1.21.0
- 1.3.0
- 1.4.0
- 1.5.0
- 1.6.0
- 1.7.0
- 1.8.0
- 1.9.0
- 1.9.1
- Affected ranges
- ECOSYSTEM: ≥ 0.9.0, < 1.22.0
Update to 1.22.0