p PatchFirst

CVE-2026-82865

CVE-2026-82865 · pdfme schemas before 5.5.10 Cross-Site Scripting via i18n Label

This page contains facts from public vulnerability sources. Check the original advisory before updating.

pdfme schemas before 5.5.10 contains a cross-site scripting vulnerability in the multiVariableText property panel that assigns unsanitized i18n label values to innerHTML. Attackers who control label overrides through options.labels can inject arbitrary JavaScript that executes when users open the Designer and select a multiVariableText field without variable placeholders.

CVSS 2.1 · Low · EPSS 0.2% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • schemas

    Versions
    • ≥ 0, < 5.5.10: Affected (semver)
    • 5.5.10: Not affected (semver)

    Update to 5.5.10

  • @pdfme/schemas npm

    Affected ranges
    • SEMVER: < 5.5.10

    Update to 5.5.10

Original sources

Check your server →