p PatchFirst

PatchFirst · Latest vulnerabilities

@pdfme/schemas vulnerabilities

Vulnerabilities published for @pdfme/schemas in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 3

  1. CVE-2026-82868

    Medium · CVSS 5.3EPSS 0.26%Fix available

    @pdfme/schemas before 5.5.9 Cross-Site Scripting via SVG

    @pdfme/schemas before 5.5.9 contains a cross-site scripting vulnerability in the SVG schema plugin that renders user-supplied SVG content directly to innerHTML without sanitization. Attackers can inject malicious SVG with embedded scripts, event handlers, or foreignObject elements to execute arbitrary JavaScript in users' browsers when viewing or filling templates.

    • Update to 5.5.9
    Published Updated
  2. CVE-2026-82867

    Medium · CVSS 5.3EPSS 0.31%Fix available

    @pdfme/schemas before 5.5.9 Cross-Site Scripting via Select

    @pdfme/schemas before 5.5.9 contains a cross-site scripting vulnerability in the Select schema plugin that fails to sanitize option values before interpolating them into HTML via innerHTML. Attackers can supply malicious templates with crafted option values containing HTML and JavaScript to execute arbitrary code in users' browsers.

    • Update to 5.5.9
    Published Updated
  3. CVE-2026-82865

    Low · CVSS 2.1EPSS 0.2%Fix available

    pdfme schemas before 5.5.10 Cross-Site Scripting via i18n Label

    pdfme schemas before 5.5.10 contains a cross-site scripting vulnerability in the multiVariableText property panel that assigns unsanitized i18n label values to innerHTML. Attackers who control label overrides through options.labels can inject arbitrary JavaScript that executes when users open the Designer and select a multiVariableText field without variable placeholders.

    • Update to 5.5.10
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →