p PatchFirst

CVE-2026-82868

CVE-2026-82868 · @pdfme/schemas before 5.5.9 Cross-Site Scripting via SVG

This page contains facts from public vulnerability sources. Check the original advisory before updating.

@pdfme/schemas before 5.5.9 contains a cross-site scripting vulnerability in the SVG schema plugin that renders user-supplied SVG content directly to innerHTML without sanitization. Attackers can inject malicious SVG with embedded scripts, event handlers, or foreignObject elements to execute arbitrary JavaScript in users' browsers when viewing or filling templates.

CVSS 5.3 · Medium · EPSS 0.3% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • schemas

    Versions
    • ≥ 0, < 5.5.9: Affected (semver)
    • 5.5.9: Not affected (semver)

    Update to 5.5.9

  • @pdfme/schemas npm

    Affected ranges
    • SEMVER: < 5.5.9

    Update to 5.5.9

Original sources

Check your server →