p PatchFirst

CVE-2026-94284

CVE-2026-94284 · Out-of-bounds read vulnerability in libX11's XIM trigger-keyregistration parser.registration parser

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An out-of-bounds read vulnerability in libX11's XIM trigger-key registration parser in libX11 before 1.8.14 could be used by malicious X servers to crash attached X clients.

CVSS 5.5 · Medium · EPSS 0.1% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • libx11

    Versions
    • ≥ 0, < 1.8.14: Affected (rpm)

    Update to 1.8.14

  • libx11 Debian:12

    Versions
    • 2:1.8.10-1
    • 2:1.8.10-2
    • 2:1.8.12-1
    • 2:1.8.13-1
    • 2:1.8.4-2
    • 2:1.8.4-2+deb12u1
    • 2:1.8.4-2+deb12u2
    • 2:1.8.6-1
    • 2:1.8.7-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • libx11 Debian:13

    Versions
    • 2:1.8.12-1
    • 2:1.8.13-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • libx11 Debian:14

    Versions
    • 2:1.8.12-1
    • 2:1.8.13-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • libx11 Ubuntu:Pro:14.04:LTS

    Versions
    • 2:1.6.1-1ubuntu1
    • 2:1.6.1-1ubuntu2
    • 2:1.6.2-1ubuntu1
    • 2:1.6.2-1ubuntu2
    • 2:1.6.2-1ubuntu2.1
    • 2:1.6.2-1ubuntu2.1+esm1
    • 2:1.6.2-1ubuntu2.1+esm2
    • 2:1.6.2-1ubuntu2.1+esm3
    • 2:1.6.2-1ubuntu2.1+esm4
    • 2:1.6.2-1ubuntu2.1+esm5
    Affected ranges
    • ECOSYSTEM: < 2:1.6.2-1ubuntu2.1+esm6

    Update to 2:1.6.2-1ubuntu2.1+esm6

  • libx11 Ubuntu:Pro:16.04:LTS

    Versions
    • 2:1.6.3-1ubuntu2
    • 2:1.6.3-1ubuntu2.1
    • 2:1.6.3-1ubuntu2.2
    • 2:1.6.3-1ubuntu2.2+esm1
    • 2:1.6.3-1ubuntu2.2+esm2
    • 2:1.6.3-1ubuntu2.2+esm3
    • 2:1.6.3-1ubuntu2.2+esm4
    Affected ranges
    • ECOSYSTEM: < 2:1.6.3-1ubuntu2.2+esm5

    Update to 2:1.6.3-1ubuntu2.2+esm5

  • libx11 Ubuntu:Pro:18.04:LTS

    Versions
    • 2:1.6.4-3
    • 2:1.6.4-3ubuntu0.1
    • 2:1.6.4-3ubuntu0.2
    • 2:1.6.4-3ubuntu0.3
    • 2:1.6.4-3ubuntu0.4
    • 2:1.6.4-3ubuntu0.4+esm1
    • 2:1.6.4-3ubuntu0.4+esm2
    Affected ranges
    • ECOSYSTEM: < 2:1.6.4-3ubuntu0.4+esm3

    Update to 2:1.6.4-3ubuntu0.4+esm3

  • libx11 Ubuntu:Pro:20.04:LTS

    Versions
    • 2:1.6.8-1
    • 2:1.6.9-2
    • 2:1.6.9-2ubuntu1
    • 2:1.6.9-2ubuntu1.1
    • 2:1.6.9-2ubuntu1.2
    • 2:1.6.9-2ubuntu1.5
    • 2:1.6.9-2ubuntu1.6
    Affected ranges
    • ECOSYSTEM: < 2:1.6.9-2ubuntu1.6+esm1

    Update to 2:1.6.9-2ubuntu1.6+esm1

  • libx11 Ubuntu:22.04:LTS

    Versions
    • 2:1.7.2-1
    • 2:1.7.2-2
    • 2:1.7.2-2build1
    • 2:1.7.5-1
    • 2:1.7.5-1ubuntu0.2
    • 2:1.7.5-1ubuntu0.3
    Affected ranges
    • ECOSYSTEM: < 2:1.7.5-1ubuntu0.4

    Update to 2:1.7.5-1ubuntu0.4

  • libx11 Ubuntu:24.04:LTS

    Versions
    • 2:1.8.6-1ubuntu1
    • 2:1.8.7-1
    • 2:1.8.7-1build1
    Affected ranges
    • ECOSYSTEM: < 2:1.8.7-1ubuntu0.1

    Update to 2:1.8.7-1ubuntu0.1

  • libx11 Ubuntu:26.10

    Versions
    • 2:1.8.13-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • libx11 Ubuntu:26.04:LTS

    Versions
    • 2:1.8.12-1build1
    • 2:1.8.12-1build2
    • 2:1.8.13-1
    Affected ranges
    • ECOSYSTEM: < 2:1.8.13-1ubuntu0.1

    Update to 2:1.8.13-1ubuntu0.1

Original sources

Check your server →