p PatchFirst

PatchFirst · Latest vulnerabilities

libx11 vulnerabilities

Vulnerabilities published for libx11 in the last 30 days: 3. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 9

  1. CVE-2026-94285

    Medium · CVSS 5.1EPSS 0.15%Fix available

    Out-of-bounds read in libX11's byte-oriented codeset parser

    An out-of-bounds read in libX11's byte-oriented codeset parser in libX11 before 1.8.14 could be used by malicious X servers to crash attached X clients.

    • Update to 2:1.7.5-1ubuntu0.4
    Published Updated
  2. CVE-2026-94284

    Medium · CVSS 5.5EPSS 0.13%Fix available

    Out-of-bounds read vulnerability in libX11's XIM trigger-keyregistration parser.registration parser

    An out-of-bounds read vulnerability in libX11's XIM trigger-key registration parser in libX11 before 1.8.14 could be used by malicious X servers to crash attached X clients.

    • Update to 2:1.7.5-1ubuntu0.4
    Published Updated
  3. CVE-2026-94283

    Medium · CVSS 6.5EPSS 0.21%Fix available

    Out-of-bounds read vulnerability in libX11's XIM (X Input Method) attribute parser

    An out-of-bounds read vulnerability in libX11's XIM (X Input Method) attribute parser in libX11 before 1.8.14 could be used by malicious X servers to crash attached X clients.

    • Update to 2:1.7.5-1ubuntu0.4
    Published Updated
  4. CVE-2023-3138

    High · CVSS 7.5EPSS 1.66%Fix available

    CVE-2023-3138

    A vulnerability was found in libX11. The security flaw occurs because the functions in src/InitExt.c in libX11 do not check that the values provided for the Request, Event, or Error IDs are within the bounds of the arrays that those functions write to, using those IDs as array indexes. They trust that they were called with values provided by an Xserver adhering to the bounds specified in the X11 protocol, as all X servers provided by X.Org do. As the protocol only specifies a single byte for these values, an out-of-bounds value provided by a malicious server (or a malicious proxy-in-the-middle) can only overwrite other portions of the Display

    • Update to 2:1.7.5-1ubuntu0.2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →