p PatchFirst

PatchFirst · Latest vulnerabilities

gimp vulnerabilities · Page 6

Vulnerabilities published for gimp in the last 30 days: 14. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 114

  1. CVE-2011-1782

    Not ratedEPSS 3.43%Fix available

    CVE-2011-1782

    Heap-based buffer overflow in the read_channel_data function in file-psp.c in the Paint Shop Pro (PSP) plugin in GIMP 2.6.11 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a PSP_COMP_RLE (aka RLE compression) image file that begins a long run count at the end of the image. NOTE: some of these details are obtained from third party information. NOTE: this vulnerability exists because of an incomplete fix for CVE-2010-4543.

    • Update to 2.6.11-3
    Published Updated
  2. CVE-2011-1178

    Not ratedEPSS 5.33%Fix available

    CVE-2011-1178

    Multiple integer overflows in the load_image function in file-pcx.c in the Personal Computer Exchange (PCX) plugin in GIMP 2.6.x and earlier allow remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted PCX image that triggers a heap-based buffer overflow.

    • Update to 2.6.10-1
    Published Updated
  3. CVE-2010-4543

    Not ratedEPSS 16.27%Public exploitFix available

    CVE-2010-4543

    Heap-based buffer overflow in the read_channel_data function in file-psp.c in the Paint Shop Pro (PSP) plugin in GIMP 2.6.11 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a PSP_COMP_RLE (aka RLE compression) image file that begins a long run count at the end of the image. NOTE: some of these details are obtained from third party information.

    • Update to 2.6.11-2
    Published Updated
  4. CVE-2010-4542

    Not ratedEPSS 5.57%Fix available

    CVE-2010-4542

    Stack-based buffer overflow in the gfig_read_parameter_gimp_rgb function in plug-ins/gfig/gfig-style.c in the GFIG plugin in GIMP 2.6.11 allows user-assisted remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a long Foreground field in a plugin configuration file. NOTE: it may be uncommon to obtain a GIMP plugin configuration file from an untrusted source that is separate from the distribution of the plugin itself. NOTE: some of these details are obtained from third party information.

    • Update to 2.6.11-2
    Published Updated
  5. CVE-2010-4541

    Not ratedEPSS 6.81%Fix available

    CVE-2010-4541

    Stack-based buffer overflow in the loadit function in plug-ins/common/sphere-designer.c in the SPHERE DESIGNER plugin in GIMP 2.6.11 allows user-assisted remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a long "Number of lights" field in a plugin configuration file. NOTE: it may be uncommon to obtain a GIMP plugin configuration file from an untrusted source that is separate from the distribution of the plugin itself.

    • Update to 2.6.11-2
    Published Updated
  6. CVE-2010-4540

    Not ratedEPSS 6.07%Fix available

    CVE-2010-4540

    Stack-based buffer overflow in the load_preset_response function in plug-ins/lighting/lighting-ui.c in the "LIGHTING EFFECTS > LIGHT" plugin in GIMP 2.6.11 allows user-assisted remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a long Position field in a plugin configuration file. NOTE: it may be uncommon to obtain a GIMP plugin configuration file from an untrusted source that is separate from the distribution of the plugin itself. NOTE: some of these details are obtained from third party information.

    • Update to 2.6.11-2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →