p PatchFirst

PatchFirst · Latest vulnerabilities

gimp vulnerabilities · Page 5

Vulnerabilities published for gimp in the last 30 days: 14. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 114

  1. CVE-2018-12713

    Critical · CVSS 9.1EPSS 1.95%No fix published

    CVE-2018-12713

    GIMP through 2.10.2 makes g_get_tmp_dir calls to establish temporary filenames, which may result in a filename that already exists, as demonstrated by the gimp_write_and_read_file function in app/tests/test-xcf.c. This might be leveraged by attackers to overwrite files or read file content that was intended to be private.

    Published Updated
  2. CVE-2013-1978

    Not ratedEPSS 4.19%Fix available

    CVE-2013-1978

    Heap-based buffer overflow in the read_xwd_cols function in file-xwd.c in the X Window Dump (XWD) plug-in in GIMP 2.6.9 and earlier allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via an X Window System (XWD) image dump with more colors than color map entries.

    • Update to 2.8.10-0.1
    Published Updated
  3. CVE-2013-1913

    Not ratedEPSS 4.07%Fix available

    CVE-2013-1913

    Integer overflow in the load_image function in file-xwd.c in the X Window Dump (XWD) plug-in in GIMP 2.6.9 and earlier, when used with glib before 2.24, allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a large color entries value in an X Window System (XWD) image dump.

    • Update to 2.8.10-0.1
    Published Updated
  4. CVE-2012-3481

    Not ratedEPSS 5.14%Fix available

    CVE-2012-3481

    Integer overflow in the ReadImage function in plug-ins/common/file-gif-load.c in the GIF image format plug-in in GIMP 2.8.x and earlier allows remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via crafted height and len properties in a GIF image file, which triggers a heap-based buffer overflow. NOTE: some of these details are obtained from third party information.

    • Update to 2.8.2-1
    Published Updated
  5. CVE-2012-3402

    Not ratedEPSS 4.28%Fix available

    CVE-2012-3402

    Integer overflow in plug-ins/common/psd.c in the Adobe Photoshop PSD plugin in GIMP 2.2.13 and earlier allows remote attackers to cause a denial of service and possibly execute arbitrary code via a crafted channels header value in a PSD image file, which triggers a heap-based buffer overflow, a different vulnerability than CVE-2009-3909.

    • Update to 2.4.0~rc1-1
    Published Updated
  6. CVE-2011-2896

    Not ratedEPSS 11.99%Fix available

    CVE-2011-2896

    The LZW decompressor in the LWZReadByte function in giftoppm.c in the David Koblas GIF decoder in PBMPLUS, as used in the gif_read_lzw function in filter/image-gif.c in CUPS before 1.4.7, the LZWReadByte function in plug-ins/common/file-gif-load.c in GIMP 2.6.11 and earlier, the LZWReadByte function in img/gifread.c in XPCE in SWI-Prolog 5.10.4 and earlier, and other products, does not properly handle code words that are absent from the decompression table when encountered, which allows remote attackers to trigger an infinite loop or a heap-based buffer overflow, and possibly execute arbitrary code, via a crafted compressed stream, a related

    • Update to 2.6.11-5
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →