p PatchFirst

PatchFirst · Latest vulnerabilities

qemu vulnerabilities · Page 11

Vulnerabilities published for qemu in the last 30 days: 14. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 485

  1. CVE-2019-20175

    High · CVSS 7.5EPSS 3.36%Fix available

    CVE-2019-20175

    An issue was discovered in ide_dma_cb() in hw/ide/core.c in QEMU 2.4.0 through 4.2.0. The guest system can crash the QEMU process in the host system via a special SCSI_IOCTL_SEND_COMMAND. It hits an assertion that implies that the size of successful DMA transfers there must be a multiple of 512 (the size of a sector). NOTE: a member of the QEMU security team disputes the significance of this issue because a "privileged guest user has many ways to cause similar DoS effect, without triggering this assert.

    • Update to 1:5.0-1
    Published Updated
  2. CVE-2013-2016

    High · CVSS 7.8EPSS 0.51%Fix available

    CVE-2013-2016

    A flaw was found in the way qemu v1.3.0 and later (virtio-rng) validates addresses when guest accesses the config space of a virtio device. If the virtio device has zero/small sized config space, such as virtio-rng, a privileged guest user could use this flaw to access the matching host's qemu address space and thus increase their privileges on the host.

    • Update to 1.5.0+dfsg-1
    Published Updated
  3. CVE-2019-12068

    Low · CVSS 3.8EPSS 0.51%Fix available

    CVE-2019-12068

    In QEMU 1:4.1-1, 1:2.1+dfsg-12+deb8u6, 1:2.8+dfsg-6+deb9u8, 1:3.1+dfsg-8~deb10u1, 1:3.1+dfsg-8+deb10u2, and 1:2.1+dfsg-12+deb8u12 (fixed), when executing script in lsi_execute_script(), the LSI scsi adapter emulator advances 's->dsp' index to read next opcode. This can lead to an infinite loop if the next opcode is empty. Move the existing loop exit after 10k iterations so that it covers no-op opcodes as well.

    • Update to 1:4.1-2
    Published Updated
  4. CVE-2019-12929

    Critical · CVSS 9.8EPSS 4.9%No fix published

    CVE-2019-12929

    The QMP guest_exec command in QEMU 4.0.0 and earlier is prone to OS command injection, which allows the attacker to achieve code execution, denial of service, or information disclosure by sending a crafted QMP command to the listening server. Note: This has been disputed as a non-issue since QEMU's -qmp interface is meant to be used by trusted users. If one is able to access this interface via a tcp socket open to the internet, then it is an insecure configuration issue

    Published Updated
  5. CVE-2019-12928

    Critical · CVSS 9.8EPSS 23.04%Public exploitNo fix published

    CVE-2019-12928

    The QMP migrate command in QEMU version 4.0.0 and earlier is vulnerable to OS command injection, which allows the remote attacker to achieve code execution, denial of service, or information disclosure by sending a crafted QMP command to the listening server. Note: This has been disputed as a non-issue since QEMU's -qmp interface is meant to be used by trusted users. If one is able to access this interface via a tcp socket open to the internet, then it is an insecure configuration issue

    Published Updated
  6. CVE-2019-3812

    Medium · CVSS 4.4EPSS 0.43%Fix available

    CVE-2019-3812

    QEMU, through version 2.10 and through version 3.1.0, is vulnerable to an out-of-bounds read of up to 128 bytes in the hw/i2c/i2c-ddc.c:i2c_ddc() function. A local attacker with permission to execute i2c commands could exploit this to read stack memory of the qemu process on the host.

    • Update to 1:3.1+dfsg-5
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →