p PatchFirst

PatchFirst · Latest vulnerabilities

redis vulnerabilities · Page 4

Vulnerabilities published for redis in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 76

  1. CVE-2021-21309

    Medium · CVSS 5.4EPSS 4.79%Fix available

    Integer overflow on 32-bit systems

    Redis is an open-source, in-memory database that persists on disk. In affected versions of Redis an integer overflow bug in 32-bit Redis version 4.0 or newer could be exploited to corrupt the heap and potentially result with remote code execution. Redis 4.0 or newer uses a configurable limit for the maximum supported bulk input size. By default, it is 512MB which is a safe value for all platforms. If the limit is significantly increased, receiving a large request from a client may trigger several integer overflow scenarios, which would result with buffer overflow and heap corruption. We believe this could in certain conditions be exploited fo

    • Update to 5:6.0.11-1
    Published Updated
  2. CVE-2020-14147

    High · CVSS 7.7EPSS 3.08%Fix available

    CVE-2020-14147

    An integer overflow in the getnum function in lua_struct.c in Redis before 6.0.3 allows context-dependent attackers with permission to run Lua code in a Redis session to cause a denial of service (memory corruption and application crash) or possibly bypass intended sandbox restrictions via a large number, which triggers a stack-based buffer overflow. NOTE: this issue exists because of a CVE-2015-8080 regression.

    • Update to 5:6.0.0-1
    Published Updated
  3. CVE-2019-10193

    High · CVSS 7.2EPSS 23.7%Fix available

    CVE-2019-10193

    A stack-buffer overflow vulnerability was found in the Redis hyperloglog data structure versions 3.x before 3.2.13, 4.x before 4.0.14 and 5.x before 5.0.4. By corrupting a hyperloglog using the SETRANGE command, an attacker could cause Redis to perform controlled increments of up to 12 bytes past the end of a stack-allocated buffer.

    • Update to 5:5.0.4-1
    Published Updated
  4. CVE-2019-10192

    High · CVSS 7.2EPSS 26.05%Fix available

    CVE-2019-10192

    A heap-buffer overflow vulnerability was found in the Redis hyperloglog data structure versions 3.x before 3.2.13, 4.x before 4.0.14 and 5.x before 5.0.4. By carefully corrupting a hyperloglog using the SETRANGE command, an attacker could trick Redis interpretation of dense HLL encoding to write up to 3 bytes beyond the end of a heap-allocated buffer.

    • Update to 5:5.0.4-1
    Published Updated
  5. CVE-2018-12326

    High · CVSS 8.4EPSS 2.58%Public exploitFix available

    CVE-2018-12326

    Buffer overflow in redis-cli of Redis before 4.0.10 and 5.x before 5.0 RC3 allows an attacker to achieve code execution and escalate to higher privileges via a crafted command line. NOTE: It is unclear whether there are any common situations in which redis-cli is used with, for example, a -h (aka hostname) argument from an untrusted source.

    • Update to 5:4.0.10-1
    Published Updated
  6. CVE-2016-8339

    Medium · CVSS 6.6EPSS 14.83%Fix available

    CVE-2016-8339

    A buffer overflow in Redis 3.2.x prior to 3.2.4 causes arbitrary code execution when a crafted command is sent. An out of bounds write vulnerability exists in the handling of the client-output-buffer-limit option during the CONFIG SET command for the Redis data structure store. A crafted CONFIG SET command can lead to an out of bounds write potentially resulting in code execution.

    • Update to 3:3.2.4-1
    Published Updated
  7. CVE-2015-8080

    High · CVSS 7.5EPSS 4.58%Fix available

    CVE-2015-8080

    Integer overflow in the getnum function in lua_struct.c in Redis 2.8.x before 2.8.24 and 3.0.x before 3.0.6 allows context-dependent attackers with permission to run Lua code in a Redis session to cause a denial of service (memory corruption and application crash) or possibly bypass intended sandbox restrictions via a large number, which triggers a stack-based buffer overflow.

    • Update to 2:3.0.5-4
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →