p PatchFirst

PatchFirst · Latest vulnerabilities

dnsjava vulnerabilities

Vulnerabilities published for dnsjava in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 3

  1. CVE-2023-50868

    High · CVSS 7.5EPSS 74.3%Fix available

    CVE-2023-50868

    The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote attackers to cause a denial of service (CPU consumption for SHA-1 computations) via DNSSEC responses in a random subdomain attack, aka the "NSEC3" issue. The RFC 5155 specification implies that an algorithm must perform thousands of iterations of a hash function in certain situations.

    • Update to 3.6.2-1
    Published Updated
  2. CVE-2023-50387

    High · CVSS 7.5EPSS 99.99%Fix available

    CVE-2023-50387

    Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to cause a denial of service (CPU consumption) via one or more DNSSEC responses, aka the "KeyTrap" issue. One of the concerns is that, when there is a zone with many DNSKEY and RRSIG records, the protocol specification implies that an algorithm must evaluate all combinations of DNSKEY and RRSIG records.

    • Update to 3.6.2-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →