p PatchFirst

PatchFirst · Latest vulnerabilities

gimp vulnerabilities · Page 6

Vulnerabilities published for gimp in the last 30 days: 14. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 122

  1. CVE-2012-3481

    Not ratedEPSS 5.14%Fix available

    CVE-2012-3481

    Integer overflow in the ReadImage function in plug-ins/common/file-gif-load.c in the GIF image format plug-in in GIMP 2.8.x and earlier allows remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via crafted height and len properties in a GIF image file, which triggers a heap-based buffer overflow. NOTE: some of these details are obtained from third party information.

    • Update to 2.8.2-1
    Published Updated
  2. CVE-2012-3402

    Not ratedEPSS 4.28%Fix available

    CVE-2012-3402

    Integer overflow in plug-ins/common/psd.c in the Adobe Photoshop PSD plugin in GIMP 2.2.13 and earlier allows remote attackers to cause a denial of service and possibly execute arbitrary code via a crafted channels header value in a PSD image file, which triggers a heap-based buffer overflow, a different vulnerability than CVE-2009-3909.

    • Update to 2.4.0~rc1-1
    Published Updated
  3. CVE-2011-2896

    Not ratedEPSS 11.99%Fix available

    CVE-2011-2896

    The LZW decompressor in the LWZReadByte function in giftoppm.c in the David Koblas GIF decoder in PBMPLUS, as used in the gif_read_lzw function in filter/image-gif.c in CUPS before 1.4.7, the LZWReadByte function in plug-ins/common/file-gif-load.c in GIMP 2.6.11 and earlier, the LZWReadByte function in img/gifread.c in XPCE in SWI-Prolog 5.10.4 and earlier, and other products, does not properly handle code words that are absent from the decompression table when encountered, which allows remote attackers to trigger an infinite loop or a heap-based buffer overflow, and possibly execute arbitrary code, via a crafted compressed stream, a related

    • Update to 2.6.11-5
    Published Updated
  4. CVE-2011-1782

    Not ratedEPSS 3.43%Fix available

    CVE-2011-1782

    Heap-based buffer overflow in the read_channel_data function in file-psp.c in the Paint Shop Pro (PSP) plugin in GIMP 2.6.11 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a PSP_COMP_RLE (aka RLE compression) image file that begins a long run count at the end of the image. NOTE: some of these details are obtained from third party information. NOTE: this vulnerability exists because of an incomplete fix for CVE-2010-4543.

    • Update to 2.6.11-3
    Published Updated
  5. CVE-2011-1178

    Not ratedEPSS 5.33%Fix available

    CVE-2011-1178

    Multiple integer overflows in the load_image function in file-pcx.c in the Personal Computer Exchange (PCX) plugin in GIMP 2.6.x and earlier allow remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted PCX image that triggers a heap-based buffer overflow.

    • Update to 2.6.10-1
    Published Updated
  6. CVE-2010-4543

    Not ratedEPSS 16.27%Public exploitFix available

    CVE-2010-4543

    Heap-based buffer overflow in the read_channel_data function in file-psp.c in the Paint Shop Pro (PSP) plugin in GIMP 2.6.11 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a PSP_COMP_RLE (aka RLE compression) image file that begins a long run count at the end of the image. NOTE: some of these details are obtained from third party information.

    • Update to 2.6.11-2
    Published Updated
  7. CVE-2010-4542

    Not ratedEPSS 5.57%Fix available

    CVE-2010-4542

    Stack-based buffer overflow in the gfig_read_parameter_gimp_rgb function in plug-ins/gfig/gfig-style.c in the GFIG plugin in GIMP 2.6.11 allows user-assisted remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a long Foreground field in a plugin configuration file. NOTE: it may be uncommon to obtain a GIMP plugin configuration file from an untrusted source that is separate from the distribution of the plugin itself. NOTE: some of these details are obtained from third party information.

    • Update to 2.6.11-2
    Published Updated
  8. CVE-2010-4541

    Not ratedEPSS 6.81%Fix available

    CVE-2010-4541

    Stack-based buffer overflow in the loadit function in plug-ins/common/sphere-designer.c in the SPHERE DESIGNER plugin in GIMP 2.6.11 allows user-assisted remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a long "Number of lights" field in a plugin configuration file. NOTE: it may be uncommon to obtain a GIMP plugin configuration file from an untrusted source that is separate from the distribution of the plugin itself.

    • Update to 2.6.11-2
    Published Updated
  9. CVE-2010-4540

    Not ratedEPSS 6.07%Fix available

    CVE-2010-4540

    Stack-based buffer overflow in the load_preset_response function in plug-ins/lighting/lighting-ui.c in the "LIGHTING EFFECTS > LIGHT" plugin in GIMP 2.6.11 allows user-assisted remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a long Position field in a plugin configuration file. NOTE: it may be uncommon to obtain a GIMP plugin configuration file from an untrusted source that is separate from the distribution of the plugin itself. NOTE: some of these details are obtained from third party information.

    • Update to 2.6.11-2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →