p PatchFirst

PatchFirst · Latest vulnerabilities

graphicsmagick vulnerabilities · Page 8

Vulnerability published for graphicsmagick in the last 30 days: 1. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 148

  1. CVE-2007-0770

    Not ratedEPSS 5.4%Fix available

    CVE-2007-0770

    Buffer overflow in GraphicsMagick and ImageMagick allows user-assisted remote attackers to cause a denial of service and possibly execute arbitrary code via a PALM image that is not properly handled by the ReadPALMImage function in coders/palm.c. NOTE: this issue is due to an incomplete patch for CVE-2006-5456.

    • Update to 1.1.7-12
    Published Updated
  2. CVE-2006-5456

    Not ratedEPSS 3.79%Fix available

    CVE-2006-5456

    Multiple buffer overflows in GraphicsMagick before 1.1.7 and ImageMagick 6.0.7 allow user-assisted attackers to cause a denial of service and possibly execute arbitrary code via (1) a DCM image that is not properly handled by the ReadDCMImage function in coders/dcm.c, or (2) a PALM image that is not properly handled by the ReadPALMImage function in coders/palm.c.

    • Update to 1.1.7-9
    Published Updated
  3. CVE-2006-4144

    Not ratedEPSS 11.03%Public exploitFix available

    CVE-2006-4144

    Integer overflow in the ReadSGIImage function in sgi.c in ImageMagick before 6.2.9 allows user-assisted attackers to cause a denial of service (crash) and possibly execute arbitrary code via large (1) bytes_per_pixel, (2) columns, and (3) rows values, which trigger a heap-based buffer overflow.

    • Update to 1.1.7-7
    Published Updated
  4. CVE-2005-0397

    Not ratedEPSS 4.22%Fix available

    CVE-2005-0397

    Format string vulnerability in the SetImageInfo function in image.c for ImageMagick before 6.0.2.5 may allow remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via format string specifiers in a filename argument to convert, which may be called by other web applications.

    • Update to 1.1.7-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →