p PatchFirst

PatchFirst · Latest vulnerabilities

krb5 vulnerabilities · Page 7

Vulnerabilities published for krb5 in the last 30 days: 2. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 129

  1. CVE-2002-0391

    Critical · CVSS 9.8EPSS 58.13%Fix available

    CVE-2002-0391

    Integer overflow in xdr_array function in RPC servers for operating systems that use libc, glibc, or other code based on SunRPC including dietlibc, allows remote attackers to execute arbitrary code by passing a large number of arguments to xdr_array through RPC services such as rpc.cmsd and dmispd.

    • Update to 1.2.5-2
    Published Updated
  2. CVE-2003-0072

    Not ratedEPSS 1.95%Fix available

    CVE-2003-0072

    The Key Distribution Center (KDC) in Kerberos 5 (krb5) 1.2.7 and earlier allows remote, authenticated attackers to cause a denial of service (crash) on KDCs within the same realm using a certain protocol request that causes an out-of-bounds read of an array (aka "array overrun").

    • Update to 1.2.7-3
    Published Updated
  3. CVE-2003-0139

    Not ratedEPSS 4.28%Fix available

    CVE-2003-0139

    Certain weaknesses in the implementation of version 4 of the Kerberos protocol (krb4) in the krb5 distribution, when triple-DES keys are used to key krb4 services, allow an attacker to create krb4 tickets for unauthorized principals using a cut-and-paste attack and "ticket splicing."

    • Update to 1.2.7-3
    Published Updated
  4. CVE-2003-0028

    Not ratedEPSS 15.03%Fix available

    CVE-2003-0028

    Integer overflow in the xdrmem_getbytes() function, and possibly other functions, of XDR (external data representation) libraries derived from SunRPC, including libnsl, libc, glibc, and dietlibc, allows remote attackers to execute arbitrary code via certain integer values in length fields, a different vulnerability than CVE-2002-0391.

    • Update to 1.3.3-2
    Published Updated
  5. CVE-2002-1235

    Not ratedEPSS 15.1%Fix available

    CVE-2002-1235

    The kadm_ser_in function in (1) the Kerberos v4compatibility administration daemon (kadmind4) in the MIT Kerberos 5 (krb5) krb5-1.2.6 and earlier, (2) kadmind in KTH Kerberos 4 (eBones) before 1.2.1, and (3) kadmind in KTH Kerberos 5 (Heimdal) before 0.5.1 when compiled with Kerberos 4 support, does not properly verify the length field of a request, which allows remote attackers to execute arbitrary code via a buffer overflow attack.

    • Update to 1.2.6-2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →