p PatchFirst

PatchFirst · Latest vulnerabilities

krb5 vulnerabilities · Page 6

Vulnerabilities published for krb5 in the last 30 days: 2. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 129

  1. CVE-2007-1216

    Not ratedEPSS 9.88%Fix available

    CVE-2007-1216

    Double free vulnerability in the GSS-API library (lib/gssapi/krb5/k5unseal.c), as used by the Kerberos administration daemon (kadmind) in MIT krb5 before 1.6.1, when used with the authentication method provided by the RPCSEC_GSS RPC library, allows remote authenticated users to execute arbitrary code and modify the Kerberos key database via a message with an "an invalid direction encoding".

    • Update to 1.4.4-8
    Published Updated
  2. CVE-2007-0957

    Not ratedEPSS 10.33%Fix available

    CVE-2007-0957

    Stack-based buffer overflow in the krb5_klog_syslog function in the kadm5 library, as used by the Kerberos administration daemon (kadmind) and Key Distribution Center (KDC), in MIT krb5 before 1.6.1 allows remote authenticated users to execute arbitrary code and modify the Kerberos key database via crafted arguments, possibly involving certain format string specifiers.

    • Update to 1.4.4-8
    Published Updated
  3. CVE-2006-6143

    Not ratedEPSS 8.12%Fix available

    CVE-2006-6143

    The RPC library in Kerberos 5 1.4 through 1.4.4, and 1.5 through 1.5.1, as used in Kerberos administration daemon (kadmind) and other products that use this library, calls an uninitialized function pointer in freed memory, which allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via unspecified vectors.

    • Update to 1.4.4-6
    Published Updated
  4. CVE-2006-3084

    Not ratedEPSS 0.5%Fix available

    CVE-2006-3084

    The (1) ftpd and (2) ksu programs in (a) MIT Kerberos 5 (krb5) up to 1.5, and 1.4.x before 1.4.4, and (b) Heimdal 0.7.2 and earlier, do not check return codes for setuid calls, which might allow local users to gain privileges by causing setuid to fail to drop privileges. NOTE: as of 20060808, it is not known whether an exploitable attack scenario exists for these issues.

    • Update to 1.4.3-9
    Published Updated
  5. CVE-2006-3083

    Not ratedEPSS 0.53%Fix available

    CVE-2006-3083

    The (1) krshd and (2) v4rcp applications in (a) MIT Kerberos 5 (krb5) up to 1.5, and 1.4.x before 1.4.4, when running on Linux and AIX, and (b) Heimdal 0.7.2 and earlier, do not check return codes for setuid calls, which allows local users to gain privileges by causing setuid to fail to drop privileges using attacks such as resource exhaustion.

    • Update to 1.4.3-9
    Published Updated
  6. CVE-2005-0468

    Not ratedEPSS 27.07%Public exploitFix available

    CVE-2005-0468

    Heap-based buffer overflow in the env_opt_add function in telnet.c for various BSD-based Telnet clients allows remote attackers to execute arbitrary code via responses that contain a large number of characters that require escaping, which consumers more memory than allocated.

    • Update to 1.3.6-2
    Published Updated
  7. CVE-2004-1189

    Not ratedEPSS 0.73%Fix available

    CVE-2004-1189

    The add_to_history function in svr_principal.c in libkadm5srv for MIT Kerberos 5 (krb5) up to 1.3.5, when performing a password change, does not properly track the password policy's history count and the maximum number of keys, which can cause an array index out-of-bounds error and may allow authenticated users to execute arbitrary code via a heap-based buffer overflow.

    • Update to 1.3.6-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →