p PatchFirst

PatchFirst · Latest vulnerabilities

libvncserver vulnerabilities · Page 3

Vulnerabilities published for libvncserver in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 45

  1. CVE-2014-6052

    Not ratedEPSS 6.75%Fix available

    CVE-2014-6052

    The HandleRFBServerMessage function in libvncclient/rfbproto.c in LibVNCServer 0.9.9 and earlier does not check certain malloc return values, which allows remote VNC servers to cause a denial of service (application crash) or possibly execute arbitrary code by specifying a large screen size in a (1) FramebufferUpdate, (2) ResizeFrameBuffer, or (3) PalmVNCReSizeFrameBuffer message.

    • Update to 0.9.9+dfsg-6.1
    Published Updated
  2. CVE-2014-6054

    Not ratedEPSS 5.54%Fix available

    CVE-2014-6054

    The rfbProcessClientNormalMessage function in libvncserver/rfbserver.c in LibVNCServer 0.9.9 and earlier allows remote attackers to cause a denial of service (divide-by-zero error and server crash) via a zero value in the scaling factor in a (1) PalmVNCSetScaleFactor or (2) SetScale message.

    • Update to 0.9.9+dfsg-6.1
    Published Updated
  3. CVE-2014-6055

    Not ratedEPSS 7.83%Fix available

    CVE-2014-6055

    Multiple stack-based buffer overflows in the File Transfer feature in rfbserver.c in LibVNCServer 0.9.9 and earlier allow remote authenticated users to cause a denial of service (crash) and possibly execute arbitrary code via a (1) long file or (2) directory name or the (3) FileTime attribute in a rfbFileTransferOffer message.

    • Update to 0.9.9+dfsg-6.1
    Published Updated
  4. CVE-2014-6051

    Not ratedEPSS 8.27%Fix available

    CVE-2014-6051

    Integer overflow in the MallocFrameBuffer function in vncviewer.c in LibVNCServer 0.9.9 and earlier allows remote VNC servers to cause a denial of service (crash) and possibly execute arbitrary code via an advertisement for a large screen size, which triggers a heap-based buffer overflow.

    • Update to 0.9.9+dfsg-6.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →