p PatchFirst

PatchFirst · Latest vulnerabilities

ruby3.3 vulnerabilities · Page 2

Vulnerabilities published for ruby3.3 in the last 30 days: 2. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 27

  1. CVE-2025-27219

    Medium · CVSS 5.8EPSS 0.85%Fix available

    CVE-2025-27219

    In the CGI gem before 0.4.2 for Ruby, the CGI::Cookie.parse method in the CGI library contains a potential Denial of Service (DoS) vulnerability. The method does not impose any limit on the length of the raw cookie value it processes. This oversight can lead to excessive resource consumption when parsing extremely large cookies.

    • Update to 3.3.7-2
    Published Updated
  2. CVE-2025-25186

    Medium · CVSS 6.5EPSS 0.63%Fix available

    Net::IMAP vulnerable to possible DoS by memory exhaustion

    Net::IMAP implements Internet Message Access Protocol (IMAP) client functionality in Ruby. Starting in version 0.3.2 and prior to versions 0.3.8, 0.4.19, and 0.5.6, there is a possibility for denial of service by memory exhaustion in `net-imap`'s response parser. At any time while the client is connected, a malicious server can send can send highly compressed `uid-set` data which is automatically read by the client's receiver thread. The response parser uses `Range#to_a` to convert the `uid-set` data into arrays of integers, with no limitation on the expanded size of the ranges. Versions 0.3.8, 0.4.19, 0.5.6, and higher fix this issue. Addi

    • Update to 3.3.8-1
    Published Updated
  3. CVE-2024-49761

    Medium · CVSS 6.6EPSS 1.42%Fix available

    REXML ReDoS vulnerability

    REXML is an XML toolkit for Ruby. The REXML gem before 3.3.9 has a ReDoS vulnerability when it parses an XML that has many digits between &# and x...; in a hex numeric character reference (&#x...;). This does not happen with Ruby 3.2 or later. Ruby 3.1 is the only affected maintained Ruby. The REXML gem 3.3.9 or later include the patch to fix the vulnerability.

    • Update to 3.3.6-1
    Published Updated
  4. CVE-2024-43398

    Medium · CVSS 5.9EPSS 1.21%Fix available

    REXML denial of service vulnerability

    REXML is an XML toolkit for Ruby. The REXML gem before 3.3.6 has a DoS vulnerability when it parses an XML that has many deep elements that have same local name attributes. If you need to parse untrusted XMLs with tree parser API like REXML::Document.new, you may be impacted to this vulnerability. If you use other parser APIs such as stream parser API and SAX2 parser API, this vulnerability is not affected. The REXML gem 3.3.6 or later include the patch to fix the vulnerability.

    • Update to 3.3.5-1
    Published Updated
  5. CVE-2024-39908

    Medium · CVSS 4.3EPSS 1.49%Fix available

    Denial of service in REXML

    REXML is an XML toolkit for Ruby. The REXML gem before 3.3.1 has some DoS vulnerabilities when it parses an XML that has many specific characters such as `<`, `0` and `%>`. If you need to parse untrusted XMLs, you many be impacted to these vulnerabilities. The REXML gem 3.3.2 or later include the patches to fix these vulnerabilities. Users are advised to upgrade. Users unable to upgrade should avoid parsing untrusted XML strings.

    • Update to 3.3.5-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →