p PatchFirst

PatchFirst · Latest vulnerabilities

thunderbird vulnerabilities · Page 57

Vulnerabilities published for thunderbird in the last 30 days: 215. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 1303

  1. CVE-2019-11691

    Critical · CVSS 9.8EPSS 1.56%Fix available

    CVE-2019-11691

    A use-after-free vulnerability can occur when working with XMLHttpRequest (XHR) in an event loop, causing the XHR main thread to be called after it has been freed. This results in a potentially exploitable crash. This vulnerability affects Thunderbird < 60.7, Firefox < 67, and Firefox ESR < 60.7.

    • Update to 1:60.7.0-1
    Published Updated
  2. CVE-2019-11693

    Critical · CVSS 9.8EPSS 2.41%Fix available

    CVE-2019-11693

    The bufferdata function in WebGL is vulnerable to a buffer overflow with specific graphics drivers on Linux. This could result in malicious content freezing a tab or triggering a potentially exploitable crash. *Note: this issue only occurs on Linux. Other operating systems are unaffected.*. This vulnerability affects Thunderbird < 60.7, Firefox < 67, and Firefox ESR < 60.7.

    • Update to 1:60.7.0-1
    Published Updated
  3. CVE-2019-11698

    Medium · CVSS 5.3EPSS 1.35%Fix available

    CVE-2019-11698

    If a crafted hyperlink is dragged and dropped to the bookmark bar or sidebar and the resulting bookmark is subsequently dragged and dropped into the web content area, an arbitrary query of a user's browser history can be run and transmitted to the content page via drop event data. This allows for the theft of browser history by a malicious site. This vulnerability affects Thunderbird < 60.7, Firefox < 67, and Firefox ESR < 60.7.

    • Update to 1:60.7.0-1
    Published Updated
  4. CVE-2019-11707

    High · CVSS 8.8EPSS 37.95%In KEVPublic exploitFix available

    CVE-2019-11707

    A type confusion vulnerability can occur when manipulating JavaScript objects due to issues in Array.pop. This can allow for an exploitable crash. We are aware of targeted attacks in the wild abusing this flaw. This vulnerability affects Firefox ESR < 60.7.1, Firefox < 67.0.3, and Thunderbird < 60.7.2.

    • Update to 1:60.7.2-1
    Published Updated
  5. CVE-2019-11708

    Critical · CVSS 10EPSS 55.87%In KEVPublic exploitFix available

    CVE-2019-11708

    Insufficient vetting of parameters passed with the Prompt:Open IPC message between child and parent processes can result in the non-sandboxed parent process opening web content chosen by a compromised child process. When combined with additional vulnerabilities this could result in executing arbitrary code on the user's computer. This vulnerability affects Firefox ESR < 60.7.2, Firefox < 67.0.4, and Thunderbird < 60.7.2.

    • Update to 1:60.7.2-1
    Published Updated
  6. CVE-2019-11709

    Critical · CVSS 9.8EPSS 2.35%Fix available

    CVE-2019-11709

    Mozilla developers and community members reported memory safety bugs present in Firefox 67 and Firefox ESR 60.7. Some of these bugs showed evidence of memory corruption and we presume that with enough effort that some of these could be exploited to run arbitrary code. This vulnerability affects Firefox ESR < 60.8, Firefox < 68, and Thunderbird < 60.8.

    • Update to 1:60.8.0-1
    Published Updated
  7. CVE-2019-11711

    High · CVSS 8.8EPSS 1.63%Fix available

    CVE-2019-11711

    When an inner window is reused, it does not consider the use of document.domain for cross-origin protections. If pages on different subdomains ever cooperatively use document.domain, then either page can abuse this to inject script into arbitrary pages on the other subdomain, even those that did not use document.domain to relax their origin security. This vulnerability affects Firefox ESR < 60.8, Firefox < 68, and Thunderbird < 60.8.

    • Update to 1:60.8.0-1
    Published Updated
  8. CVE-2019-11712

    High · CVSS 8.8EPSS 1.05%Fix available

    CVE-2019-11712

    POST requests made by NPAPI plugins, such as Flash, that receive a status 308 redirect response can bypass CORS requirements. This can allow an attacker to perform Cross-Site Request Forgery (CSRF) attacks. This vulnerability affects Firefox ESR < 60.8, Firefox < 68, and Thunderbird < 60.8.

    • Update to 1:60.8.0-1
    Published Updated
  9. CVE-2019-11719

    High · CVSS 7.5EPSS 2.29%Fix available

    CVE-2019-11719

    When importing a curve25519 private key in PKCS#8format with leading 0x00 bytes, it is possible to trigger an out-of-bounds read in the Network Security Services (NSS) library. This could lead to information disclosure. This vulnerability affects Firefox ESR < 60.8, Firefox < 68, and Thunderbird < 60.8.

    • Update to 1:60.8.0-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →