p PatchFirst

PatchFirst · Latest vulnerabilities

firefox-esr vulnerabilities · Page 54

Vulnerabilities published for firefox-esr in the last 30 days: 206. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 1349

  1. CVE-2019-11707

    High · CVSS 8.8EPSS 37.95%In KEVPublic exploitFix available

    CVE-2019-11707

    A type confusion vulnerability can occur when manipulating JavaScript objects due to issues in Array.pop. This can allow for an exploitable crash. We are aware of targeted attacks in the wild abusing this flaw. This vulnerability affects Firefox ESR < 60.7.1, Firefox < 67.0.3, and Thunderbird < 60.7.2.

    • Update to 60.7.1esr-1
    Published Updated
  2. CVE-2019-11708

    Critical · CVSS 10EPSS 55.87%In KEVPublic exploitFix available

    CVE-2019-11708

    Insufficient vetting of parameters passed with the Prompt:Open IPC message between child and parent processes can result in the non-sandboxed parent process opening web content chosen by a compromised child process. When combined with additional vulnerabilities this could result in executing arbitrary code on the user's computer. This vulnerability affects Firefox ESR < 60.7.2, Firefox < 67.0.4, and Thunderbird < 60.7.2.

    • Update to 60.7.2esr-1
    Published Updated
  3. CVE-2019-11709

    Critical · CVSS 9.8EPSS 2.35%Fix available

    CVE-2019-11709

    Mozilla developers and community members reported memory safety bugs present in Firefox 67 and Firefox ESR 60.7. Some of these bugs showed evidence of memory corruption and we presume that with enough effort that some of these could be exploited to run arbitrary code. This vulnerability affects Firefox ESR < 60.8, Firefox < 68, and Thunderbird < 60.8.

    • Update to 60.8.0esr-1
    Published Updated
  4. CVE-2019-11711

    High · CVSS 8.8EPSS 1.63%Fix available

    CVE-2019-11711

    When an inner window is reused, it does not consider the use of document.domain for cross-origin protections. If pages on different subdomains ever cooperatively use document.domain, then either page can abuse this to inject script into arbitrary pages on the other subdomain, even those that did not use document.domain to relax their origin security. This vulnerability affects Firefox ESR < 60.8, Firefox < 68, and Thunderbird < 60.8.

    • Update to 60.8.0esr-1
    Published Updated
  5. CVE-2019-11712

    High · CVSS 8.8EPSS 1.05%Fix available

    CVE-2019-11712

    POST requests made by NPAPI plugins, such as Flash, that receive a status 308 redirect response can bypass CORS requirements. This can allow an attacker to perform Cross-Site Request Forgery (CSRF) attacks. This vulnerability affects Firefox ESR < 60.8, Firefox < 68, and Thunderbird < 60.8.

    • Update to 60.8.0esr-1
    Published Updated
  6. CVE-2019-11719

    High · CVSS 7.5EPSS 2.29%Fix available

    CVE-2019-11719

    When importing a curve25519 private key in PKCS#8format with leading 0x00 bytes, it is possible to trigger an out-of-bounds read in the Network Security Services (NSS) library. This could lead to information disclosure. This vulnerability affects Firefox ESR < 60.8, Firefox < 68, and Thunderbird < 60.8.

    • Update to 60.8.0esr-1
    Published Updated
  7. CVE-2019-11730

    Medium · CVSS 6.5EPSS 20.27%Fix available

    CVE-2019-11730

    A vulnerability exists where if a user opens a locally saved HTML file, this file can use file: URIs to access other files in the same directory or sub-directories if the names are known or guessed. The Fetch API can then be used to read the contents of any files stored in these directories and they may uploaded to a server. It was demonstrated that in combination with a popular Android messaging app, if a malicious HTML attachment is sent to a user and they opened that attachment in Firefox, due to that app's predictable pattern for locally-saved file names, it is possible to read attachments the victim received from other correspondents. Th

    • Update to 60.8.0esr-1
    Published Updated
  8. CVE-2019-13075

    Medium · CVSS 5.3EPSS 1.86%Fix available

    CVE-2019-13075

    Tor Browser through 8.5.3 has an information exposure vulnerability. It allows remote attackers to detect the browser's language via vectors involving an IFRAME element, because text in that language is included in the title attribute of a LINK element for a non-HTML page. This is related to a behavior of Firefox before 68.

    • Update to 68.2.0esr-1
    Published Updated
  9. CVE-2019-9796

    Critical · CVSS 9.8EPSS 2.06%Fix available

    CVE-2019-9796

    A use-after-free vulnerability can occur when the SMIL animation controller incorrectly registers with the refresh driver twice when only a single registration is expected. When a registration is later freed with the removal of the animation controller element, the refresh driver incorrectly leaves a dangling pointer to the driver's observer array. This vulnerability affects Thunderbird < 60.6, Firefox ESR < 60.6, and Firefox < 66.

    • Update to 60.6.0esr-1
    Published Updated
  10. CVE-2019-9793

    Medium · CVSS 5.9EPSS 1.63%Fix available

    CVE-2019-9793

    A mechanism was discovered that removes some bounds checking for string, array, or typed array accesses if Spectre mitigations have been disabled. This vulnerability could allow an attacker to create an arbitrary value in compiled JavaScript, for which the range analysis will infer a fully controlled, incorrect range in circumstances where users have explicitly disabled Spectre mitigations. *Note: Spectre mitigations are currently enabled for all users by default settings.*. This vulnerability affects Thunderbird < 60.6, Firefox ESR < 60.6, and Firefox < 66.

    • Update to 60.6.0esr-1
    Published Updated
  11. CVE-2019-9792

    Critical · CVSS 9.8EPSS 13.3%Public exploitFix available

    CVE-2019-9792

    The IonMonkey just-in-time (JIT) compiler can leak an internal JS_OPTIMIZED_OUT magic value to the running script during a bailout. This magic value can then be used by JavaScript to achieve memory corruption, which results in a potentially exploitable crash. This vulnerability affects Thunderbird < 60.6, Firefox ESR < 60.6, and Firefox < 66.

    • Update to 60.6.0esr-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →