p PatchFirst

PatchFirst · Latest vulnerabilities

phpunit vulnerabilities

Vulnerability published for phpunit in the last 30 days: 1. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 3

  1. CVE-2026-119193

    Medium · CVSS 5.4EPSS 0.11%Public exploitFix available

    PHPUnit vulnerable to code execution by other local users via shared temporary directory in PHPT code coverage handling

    PHPUnit is a testing framework for PHP. From 13.4.0 until 13.4.4, the TestCase::coverageFilesDirectory() logic in src/Runner/Phpt/TestCase.php creates temporary files for PHPT code coverage in a predictable phpunit-phpt directory under sys_get_temp_dir() and reuses that directory without verifying its ownership or permissions. On multi-user systems with a shared temporary path, a local attacker who creates the directory before the developer runs PHPT tests with code coverage can replace the generated job file before the child process executes it with require, allowing arbitrary code execution with the developer's privileges while the test and

    • Update to 13.4.5+ds-1
    Published Updated
  2. CVE-2026-24765

    High · CVSS 7.8EPSS 0.38%Fix available

    PHPUnit Vulnerable to Unsafe Deserialization in PHPT Code Coverage Handling

    PHPUnit is a testing framework for PHP. A vulnerability has been discovered in versions prior to 12.5.8, 11.5.50, 10.5.62, 9.6.33, and 8.5.52 involving unsafe deserialization of code coverage data in PHPT test execution. The vulnerability exists in the `cleanupForCoverage()` method, which deserializes code coverage files without validation, potentially allowing remote code execution if malicious `.coverage` files are present prior to the execution of the PHPT test. The vulnerability occurs when a `.coverage` file, which should not exist before test execution, is deserialized without the `allowed_classes` parameter restriction. An attacker wit

    • Update to 12.5.8-1
    Published Updated
  3. CVE-2017-9841

    Critical · CVSS 9.8EPSS 100%In KEVPublic exploitFix available

    CVE-2017-9841

    Util/PHP/eval-stdin.php in PHPUnit before 4.8.28 and 5.x before 5.6.3 allows remote attackers to execute arbitrary PHP code via HTTP POST data beginning with a "<?php " substring, as demonstrated by an attack on a site with an exposed /vendor folder, i.e., external access to the /vendor/phpunit/phpunit/src/Util/PHP/eval-stdin.php URI.

    • Update to 5.4.6-2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →