p PatchFirst

PatchFirst · Latest vulnerabilities

thrift vulnerabilities · Page 4

Vulnerabilities published for thrift in the last 30 days: 61. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 91

  1. CVE-2026-94635

    High · CVSS 8.7EPSS 0.34%No fix published

    Apache Thrift: Lua `TBinaryProtocol:readMessageBegin` bypasses `checkStringSize` on the pre-versioned name

    Allocation of resources without limits or throttling, Improper handling of length parameter inconsistency vulnerability in Apache Thrift Lua bindings. This issue affects Apache Thrift: before 0.25.0. Users are recommended to upgrade to version 0.25.0, which fixes the issue.

    Published Updated
  2. CVE-2026-66053

    Medium · CVSS 5.9EPSS 0.29%Fix available

    Apache Thrift: Python TSSLSocket Hostname Matcher Import

    Improper Validation of Certificate with Host Mismatch vulnerability in Apache Thrift Python bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue. This replaces CVE-2026-41603

    • Update to 0.23.0-3
    Published Updated
  3. CVE-2026-58662

    High · CVSS 8.7EPSS 1.08%Fix available

    Apache Thrift: C++ THeaderTransport::readString() info-header length bounds bypass

    Improper Validation of Specified Quantity in Input, Out-of-bounds Read vulnerability in Apache Thrift C++ bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

    • Update to 0.24.0-2
    Published Updated
  4. CVE-2026-58389

    High · CVSS 8.7EPSS 1.03%Fix available

    Apache Thrift: Rust binary protocol non-strict path missing string size limit

    Allocation of Resources Without Limits or Throttling vulnerability in Apache Thrift Rust bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

    • Update to 0.24.0-2
    Published Updated
  5. CVE-2026-55969

    High · CVSS 8.7EPSS 1.03%Fix available

    Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift: integer overflow in TProtocol::checkReadBytesAvailable()

    Integer Overflow or Wraparound vulnerability in Apache Thrift C++, c_glib, Go, netstd, Delphi and Haxe bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

    • Update to 0.24.0-2
    Published Updated
  6. CVE-2026-55968

    High · CVSS 8.7EPSS 1.03%Fix available

    Apache Thrift: Node.js quadratic-time DoS in server receive transports

    Inefficient Algorithmic Complexity, Allocation of Resources Without Limits or Throttling vulnerability in Apache Thrift Node.js bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

    • Update to 0.24.0-2
    Published Updated
  7. CVE-2026-48586

    High · CVSS 8.7EPSS 1.03%Fix available

    Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift: TZlibTransport Decompression Size Limit

    Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift C++, Java, Python, Go, D, C/GLib bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

    • Update to 0.24.0-2
    Published Updated
  8. CVE-2026-43871

    High · CVSS 8.7EPSS 1.03%Fix available

    Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift: TCompactProtocol varint byte-count limit

    Loop with Unreachable Exit Condition ('Infinite Loop') vulnerability in Apache Thrift Python, Go, PHP and Java bindings.This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

    • Update to 0.24.0-2
    Published Updated
  9. CVE-2026-41608

    High · CVSS 7.5EPSS 1.03%Fix available

    Apache Thrift: Unbounded Zlib Decompression in Python THeaderTransport

    Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift Python bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

    • Update to 0.24.0-2
    Published Updated
  10. CVE-2026-43870

    High · CVSS 7.3EPSS 0.38%Fix available

    Apache Thrift: Node.js web_server.js multi-vulnerability

    Origin Validation Error, Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal'), Improper Neutralization of CRLF Sequences in HTTP Headers ('HTTP Request/Response Splitting'), Uncontrolled Resource Consumption vulnerability in Apache Thrift. This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version 0.23.0, which fixes the issue.

    • Update to 0.23.0-3

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →