p PatchFirst

PatchFirst · Latest vulnerabilities

thrift vulnerabilities · Page 5

Vulnerabilities published for thrift in the last 30 days: 61. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 91

  1. CVE-2025-48431

    High · CVSS 7.5EPSS 1.04%Fix available

    Apache Thrift: Specially crafted input can crash a c_glib Thrift server with invalid pointer error.

    Mismatched Memory Management Routines vulnerability in Apache Thrift c_glib language bindings. This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version 0.23.0, which fixes the issue. Description: Specially crafted requests can crash an c_glib-based Thrift server with a clean but fatal "free(): invalid pointer" error message.

    • Update to 0.23.0-3
    Published Updated
  2. CVE-2019-0205

    High · CVSS 7.5EPSS 9.16%Public exploitFix available

    CVE-2019-0205

    In Apache Thrift all versions up to and including 0.12.0, a server or client may run into an endless loop when feed with specific input data. Because the issue had already been partially fixed in version 0.11.0, depending on the installed version it affects only certain language bindings.

    • Update to 0.13.0-2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →