GHSA-27qr-636m-wxg2
GHSA-27qr-636m-wxg2 · codeigniter/framework SQL injection in ODBC database driver
This page contains facts from public vulnerability sources. Check the original advisory before updating.
CodeIgniter 3.1.0 addressed a critical security issue within the ODBC database driver. This update includes crucial fixes to mitigate a SQL injection vulnerability, preventing potential exploitation by attackers. It is noteworthy that these fixes render the query builder and escape() functions incompatible with the ODBC driver. However, the update introduces actual query binding as a more secure alternative.
CVSS 10.0 · Critical · Fix available
- Published
- Updated
Stack: php
Affected products and versions
codeigniter/framework Packagist
- Versions
- 3.0.0
- 3.0.1
- 3.0.1rc
- 3.0.1rc2
- 3.0.2
- 3.0.3
- 3.0.4
- 3.0.5
- 3.0.6
- 3.0rc
- 3.0rc2
- 3.0rc3
- Affected ranges
- ECOSYSTEM: < 3.1.0
Update to 3.1.0
Original sources
- https://github.com/simplysites/CodeIgniter/commit/3d10ffa77854044570a1809a884776fd4bbd8b70
- https://forum.codeigniter.com/thread-65803.html
- https://github.com/FriendsOfPHP/security-advisories/blob/master/codeigniter/framework/2016-07-26-1.yaml
- https://github.com/simplysites/CodeIgniter
- https://osv.dev/vulnerability/GHSA-27qr-636m-wxg2