GHSA-q9j3-4ghj-6h57
GHSA-q9j3-4ghj-6h57 · Inadequate XSS Prevention in CodeIgniter/Framework Security Library
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The xss_clean() method in the Security Library of CodeIgniter/Framework, specifically in versions before 3.0.3, exhibited a vulnerability that allowed certain Cross-Site Scripting (XSS) vectors to bypass its intended protection mechanisms. The xss_clean() method is designed to sanitize input data by removing potentially malicious content, thus preventing XSS attacks. However, in versions prior to 3.0.3, it was discovered that the method did not adequately mitigate specific XSS vectors, leaving a potential security gap.
CVSS 4.7 · Medium · Fix available
- Published
- Updated
Stack: php
Affected products and versions
codeigniter/framework Packagist
- Versions
- 3.0.0
- 3.0.1
- 3.0.1rc
- 3.0.1rc2
- 3.0.2
- 3.0rc
- 3.0rc2
- 3.0rc3
- Affected ranges
- ECOSYSTEM: < 3.0.3
Update to 3.0.3
Original sources
- https://github.com/bcit-ci/CodeIgniter/commit/71b1b3f5b2dcc0f4b652e9494e9853b82541ac8c
- https://github.com/FriendsOfPHP/security-advisories/blob/master/codeigniter/framework/2015-10-31-1.yaml
- https://github.com/bcit-ci/CodeIgniter
- https://www.codeigniter.com/user_guide/changelog.html#version-3-0-3
- https://osv.dev/vulnerability/GHSA-q9j3-4ghj-6h57