GHSA-v457-wxvj-p9w9
GHSA-v457-wxvj-p9w9 · @vitejs/plugin-rsc has a Denial of Service with React Server Components
This page contains facts from public vulnerability sources. Check the original advisory before updating.
### Impact `@vitejs/plugin-rsc` vendors `react-server-dom-webpack`, which contained a vulnerability in versions prior to 19.2.4. See details in React repository's advisory https://github.com/facebook/react/security/advisories/GHSA-479c-33wc-g2pg ### Patches Upgrade immediately to `@vitejs/[email protected]` or later.
CVSS 7.5 · High · Fix available
- Published
- Updated
Stack: node
Affected products and versions
@vitejs/plugin-rsc npm
- Affected ranges
- SEMVER: < 0.5.23
Update to 0.5.23