p PatchFirst

PatchFirst · Latest vulnerabilities

@vitejs/plugin-rsc vulnerabilities

Vulnerabilities published for @vitejs/plugin-rsc in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 7

  1. GHSA-w94c-4vhp-22gx

    High · CVSS 7.5Fix available

    @vitejs/plugin-rsc has a Denial of Service Vulnerability in React Server Components

    ### Impact `@vitejs/plugin-rsc` vendors `react-server-dom-webpack`, which contained a vulnerability in versions prior to 19.2.6. See details in React repository's advisory https://github.com/facebook/react/security/advisories/GHSA-rv78-f8rc-xrxh ### Patches Upgrade immediately to `@vitejs/[email protected]` or later.

    • Update to 0.5.26
    Published Updated
  2. GHSA-v457-wxvj-p9w9

    High · CVSS 7.5Fix available

    @vitejs/plugin-rsc has a Denial of Service with React Server Components

    ### Impact `@vitejs/plugin-rsc` vendors `react-server-dom-webpack`, which contained a vulnerability in versions prior to 19.2.4. See details in React repository's advisory https://github.com/facebook/react/security/advisories/GHSA-479c-33wc-g2pg ### Patches Upgrade immediately to `@vitejs/[email protected]` or later.

    • Update to 0.5.23
    Published Updated
  3. CVE-2025-68155

    High · CVSS 7.5EPSS 0.5%Fix available

    @vitejs/plugin-rsc has Arbitrary File Read via `/__vite_rsc_findSourceMapURL` Endpoint on Development

    @vitejs/plugin-rs provides React Server Components (RSC) support for Vite. Prior to version 0.5.8, the `/__vite_rsc_findSourceMapURL` endpoint in `@vitejs/plugin-rsc` allows unauthenticated arbitrary file read during development mode. An attacker can read any file accessible to the Node.js process by sending a crafted HTTP request with a `file://` URL in the `filename` query parameter. Version 0.5.8 fixes the issue.

    • Update to 0.5.8
    Published Updated
  4. GHSA-c6m7-q6pr-c64r

    Medium · CVSS 5.3Fix available

    Vite Plugin React has a Source Code Exposure Vulnerability in React Server Components

    ### Impact `@vitejs/plugin-rsc` vendors `react-server-dom-webpack`, which contained a vulnerability in versions prior to 19.2.3. See details in React repository's advisory https://github.com/facebook/react/security/advisories/GHSA-925w-6v3x-g4j4 ### Patches Upgrade immediately to `@vitejs/[email protected]` or later.

    • Update to 0.5.7
    Published Updated
  5. GHSA-cpqf-f22c-r95x

    High · CVSS 7.5Fix available

    Vite Plugin React has a Denial of Service Vulnerability in React Server Components

    ### Impact `@vitejs/plugin-rsc` vendors `react-server-dom-webpack`, which contained a vulnerability in versions prior to 19.2.3. See details in React repository's advisory https://github.com/facebook/react/security/advisories/GHSA-7gmr-mq3h-m5h9 ### Patches Upgrade immediately to `@vitejs/[email protected]` or later.

    • Update to 0.5.7
    Published Updated
  6. CVE-2025-67489

    Critical · CVSS 9.8EPSS 0.81%Fix available

    @vitejs/plugin-rsc Remote Code Execution through unsafe dynamic imports in RSC server function APIs on development server

    @vitejs/plugin-rs provides React Server Components (RSC) support for Vite. Versions 0.5.5 and below are vulnerable to arbitrary remote code execution on the development server through unsafe dynamic imports in server function APIs (loadServerAction, decodeReply, decodeAction) when integrated into RSC applications that expose server function endpoints. Attackers with network access to the development server can read/modify files, exfiltrate sensitive data (source code, environment variables, credentials), or pivot to other internal services. While this affects development servers only, the risk increases when using vite --host to expose the se

    • Update to 0.5.6
    Published Updated
  7. GHSA-fmh4-wr37-44fp

    Critical · CVSS 10Fix available

    React Server Components are Vulnerable to RCE

    ### Summary `@vitejs/plugin-rsc` vendors `react-server-dom-webpack`, which contained an unauthenticated remote code execution vulnerability in versions prior to 19.0.1, 19.1.2, and 19.2.1. See details in React repository's advisory https://github.com/facebook/react/security/advisories/GHSA-fv66-9v8q-g76r ### Impact Applications using affected versions of `@vitejs/plugin-rsc` are vulnerable to unauthenticated remote code execution through deserialization of untrusted data. An attacker can execute arbitrary code remotely without authentication, affecting confidentiality, integrity, and availability. ### Recommendations Upgrade immediately

    • Update to 0.5.3
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →