p PatchFirst

PatchFirst · Latest vulnerabilities

org.apache.spark:spark-core_2.11 vulnerabilities

Vulnerabilities published for org.apache.spark:spark-core_2.11 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 4

  1. CVE-2022-31777

    Medium · CVSS 5.4EPSS 1.82%No fix published

    Apache Spark XSS vulnerability in log viewer UI Javascript

    A stored cross-site scripting (XSS) vulnerability in Apache Spark 3.2.1 and earlier, and 3.3.0, allows remote attackers to execute arbitrary JavaScript in the web browser of a user, by including a malicious payload into the logs which would be returned in logs rendered in the UI.

    Published Updated
  2. CVE-2019-10099

    High · CVSS 8.7EPSS 1.3%Fix available

    CVE-2019-10099

    Prior to Spark 2.3.3, in certain situations Spark would write user data to local disk unencrypted, even if spark.io.encryption.enabled=true. This includes cached blocks that are fetched to disk (controlled by spark.maxRemoteBlockSizeFetchToMem); in SparkR, using parallelize; in Pyspark, using broadcast and parallelize; and use of python udfs.

    • Update to 2.3.3
    Published Updated
  3. CVE-2018-1334

    Medium · CVSS 6EPSS 0.51%Fix available

    CVE-2018-1334

    In Apache Spark 1.0.0 to 2.1.2, 2.2.0 to 2.2.1, and 2.3.0, when using PySpark or SparkR, it's possible for a different local user to connect to the Spark application and impersonate the user running the Spark application.

    • Update to 2.1.3
    • Update to 2.2.2
    • Update to 2.3.1
    Published Updated
  4. CVE-2017-12612

    High · CVSS 8.5EPSS 0.73%Fix available

    CVE-2017-12612

    In Apache Spark 1.6.0 until 2.1.1, the launcher API performs unsafe deserialization of data received by its socket. This makes applications launched programmatically using the launcher API potentially vulnerable to arbitrary code execution by an attacker with access to any user account on the local machine. It does not affect apps run by spark-submit or spark-shell. The attacker would be able to execute code as the user that ran the Spark application. Users are encouraged to update to version 2.2.0 or later.

    • Update to 2.1.2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →