p PatchFirst

PatchFirst · Latest vulnerabilities

@apollo/composition vulnerabilities

Vulnerabilities published for @apollo/composition in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 2

  1. GHSA-m8jr-fxqx-8xx6

    High · CVSS 7.5Fix available

    Apollo Federation has Improper Enforcement of Access Control on Transitive Fields

    # Summary A vulnerability in Apollo Federation's composition logic did not enforce that fields depending on protected data through `@requires` and/or `@fromContext` directives have the same access control requirements as the fields they reference. This allowed queries to access protected fields indirectly through their dependencies, bypassing access control checks. A fix to composition logic in Federation now enforces that dependent fields match the access control requirements from of the fields they reference. ## Details Apollo Federation allows users to specify [`@authenticated`, `@requiresScopes`, and `@policy` directives](https://www.apo

    • Update to 2.10.4
    • Update to 2.11.5
    • Update to 2.12.1
    • Update to 2.9.5
    Published Updated
  2. CVE-2025-64530

    High · CVSS 7.5EPSS 0.41%Fix available

    @apollo/composition has Improper Enforcement of Access Control on Interface Types and Fields

    Apollo Federation is an architecture for declaratively composing APIs into a unified graph. A vulnerability in versions of Apollo Federation's composition logic prior to 2.9.5, 2.10.4, 2.11.5, and 2.12.1 allowed some queries to Apollo Router to improperly bypass access controls on types/fields. Apollo Federation incorrectly allowed user-defined access control directives on interface types/fields, which could be bypassed by instead querying the implementing object types/fields in Apollo Router via inline fragments, for example. A fix to versions 2.9.5, 2.10.4, 2.11.5, and 2.12.1 of composition logic in Federation now disallows interfaces types

    • Update to 2.10.4
    • Update to 2.11.5
    • Update to 2.12.1
    • Update to 2.9.5
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →