p PatchFirst

PatchFirst · Latest vulnerabilities

@apollo/query-planner vulnerabilities

Vulnerabilities published for @apollo/query-planner in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 2

  1. CVE-2026-32621

    Critical · CVSS 9.9EPSS 0.54%Fix available

    Apollo Federation has prototype pollution via incomplete key sanitization

    Apollo Federation is an architecture for declaratively composing APIs into a unified graph. Prior to 2.9.6, 2.10.5, 2.11.6, 2.12.3, and 2.13.2, a vulnerability exists in query plan execution within the gateway that may allow pollution of Object.prototype in certain scenarios. A malicious client may be able to pollute Object.prototype in gateway directly by crafting operations with field aliases and/or variable names that target prototype-inheritable properties. Alternatively, if a subgraph were to be compromised by a malicious actor, they may be able to pollute Object.prototype in gateway by crafting JSON response payloads that target prototy

    • Update to 2.10.5
    • Update to 2.11.6
    • Update to 2.12.3
    • Update to 2.13.2
    • Update to 2.9.6
    Published Updated
  2. CVE-2024-43414

    High · CVSS 7.5EPSS 0.99%Fix available

    Apollo Query Planner and Apollo Gateway may infinitely loop on sufficiently complex queries

    Apollo Federation is an architecture for declaratively composing APIs into a unified graph. Each team can own their slice of the graph independently, empowering them to deliver autonomously and incrementally. Instances of @apollo/query-planner >=2.0.0 and <2.8.5 are impacted by a denial-of-service vulnerability. @apollo/gateway versions >=2.0.0 and < 2.8.5 and Apollo Router <1.52.1 are also impacted through their use of @apollo/query-panner. If @apollo/query-planner is asked to plan a sufficiently complex query, it may loop infinitely and never complete. This results in unbounded memory consumption and either a crash or out-of-memory (OOM) te

    • Update to 2.8.5
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →