p PatchFirst

PatchFirst · Latest vulnerabilities

@better-auth/drizzle-adapter vulnerabilities

Vulnerability published for @better-auth/drizzle-adapter in the last 30 days: 1. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerability: 1

  1. CVE-2026-110861

    Medium · CVSS 6.3EPSS 0.22%Fix available

    Better Auth drizzle-adapter 1.6.17 before 1.7.7 Rate Limit Bypass via Race Condition

    Better Auth @better-auth/drizzle-adapter and better-auth from 1.6.17 before 1.7.7, and @better-auth/kysely-adapter from 1.6.17 before 1.7.0, contain a race condition in database-backed rate limiting on PostgreSQL where the limit check is not atomic with the counter update. Remote attackers can send bursts of concurrent requests that pass the check together, exceeding configured limits on password sign-in, two-factor verification, one-time code, password reset, and other rate-limited endpoints.

    • Update to 1.7.7
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →