p PatchFirst

PatchFirst · Latest vulnerabilities

@cyanheads/git-mcp-server vulnerabilities

Vulnerabilities published for @cyanheads/git-mcp-server in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerability: 1

  1. CVE-2025-53107

    High · CVSS 7.5EPSS 24.54%Fix available

    @cyanheads/git-mcp-server vulnerable to command injection in several tools

    @cyanheads/git-mcp-server is an MCP server designed to interact with Git repositories. Prior to version 2.1.5, there is a command injection vulnerability caused by the unsanitized use of input parameters within a call to child_process.exec, enabling an attacker to inject arbitrary system commands. Successful exploitation can lead to remote code execution under the server process's privileges. The server constructs and executes shell commands using unvalidated user input directly within command-line strings. This introduces the possibility of shell metacharacter injection (|, >, &&, etc.). An MCP Client can be instructed to execute additional

    • Update to 2.1.5
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →