p PatchFirst

PatchFirst · Latest vulnerabilities

@fastify/http-proxy vulnerabilities

Vulnerabilities published for @fastify/http-proxy in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerability: 1

  1. CVE-2026-33805

    Critical · CVSS 9EPSS 0.44%Fix available

    @fastify/reply-from vulnerable to connection header abuse enabling stripping of proxy-added headers

    @fastify/reply-from v12.6.1 and earlier and @fastify/http-proxy v11.4.3 and earlier process the client's Connection header after the proxy has added its own headers via rewriteRequestHeaders. This allows attackers to retroactively strip proxy-added headers from upstream requests by listing them in the Connection header value. Any header added by the proxy for routing, access control, or security purposes can be selectively removed by a client. @fastify/http-proxy is also affected as it delegates to @fastify/reply-from. Upgrade to @fastify/reply-from v12.6.2 or @fastify/http-proxy v11.4.4 or later.

    • Update to 11.4.4
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →