p PatchFirst

PatchFirst · Latest vulnerabilities

@fastify/reply-from vulnerabilities

Vulnerabilities published for @fastify/reply-from in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 3

  1. CVE-2026-33805

    Critical · CVSS 9EPSS 0.44%Fix available

    @fastify/reply-from vulnerable to connection header abuse enabling stripping of proxy-added headers

    @fastify/reply-from v12.6.1 and earlier and @fastify/http-proxy v11.4.3 and earlier process the client's Connection header after the proxy has added its own headers via rewriteRequestHeaders. This allows attackers to retroactively strip proxy-added headers from upstream requests by listing them in the Connection header value. Any header added by the proxy for routing, access control, or security purposes can be selectively removed by a client. @fastify/http-proxy is also affected as it delegates to @fastify/reply-from. Upgrade to @fastify/reply-from v12.6.2 or @fastify/http-proxy v11.4.4 or later.

    • Update to 12.6.2
    Published Updated
  2. CVE-2025-66415

    Medium · CVSS 6.9EPSS 0.19%Fix available

    fastify-reply-from bypass of reply forwarding

    fastify-reply-from is a Fastify plugin to forward the current HTTP request to another server. Prior to 12.5.0, by crafting a malicious URL, an attacker could access routes that are not allowed, even though the reply.from is defined for specific routes in @fastify/reply-from. This vulnerability is fixed in 12.5.0.

    • Update to 12.5.0
    Published Updated
  3. CVE-2023-51701

    Medium · CVSS 5.3EPSS 0.48%Fix available

    @fastify-reply-from JSON Content-Type parsing confusion

    fastify-reply-from is a Fastify plugin to forward the current HTTP request to another server. A reverse proxy server built with `@fastify/reply-from` could misinterpret the incoming body by passing an header `ContentType: application/json ; charset=utf-8`. This can lead to bypass of security checks. This vulnerability has been patched in '@fastify/reply-from` version 9.6.0.

    • Update to 9.6.0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →