p PatchFirst

PatchFirst · Latest vulnerabilities

@github/copilot vulnerabilities

Vulnerabilities published for @github/copilot in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 2

  1. CVE-2026-45033

    High · CVSS 8.5EPSS 0.35%Fix available

    GitHub Copilot CLI: Nested Bare Repository Can Execute Arbitrary Commands via core.fsmonitor

    GitHub Copilot CLI brings AI-powered coding assistance directly to your command line. Prior to 1.0.43, a security vulnerability has been identified in GitHub Copilot CLI where a malicious bare git repository nested inside a project directory can achieve arbitrary code execution when the agent performs git operations. By exploiting git's automatic bare repository discovery during directory traversal, an attacker can set core.fsmonitor or other executable config keys to run arbitrary commands without user awareness or approval. The vulnerability arises because git's core.fsmonitor config key (and 15+ similar keys such as core.hookspath, diff.e

    • Update to 1.0.43
    Published Updated
  2. CVE-2026-29783

    High · CVSS 7.5EPSS 0.47%Fix available

    GitHub Copilot CLI allows for dangerous shell expansion patterns that enable arbitrary command execution

    The shell tool within GitHub Copilot CLI versions prior to and including 0.0.422 can allow arbitrary code execution through crafted bash parameter expansion patterns. An attacker who can influence the commands executed by the agent (e.g., via prompt injection through repository files, MCP server responses, or user instructions) can exploit bash parameter transformation operators to execute hidden commands, bypassing the safety assessment that classifies commands as "read-only." This has been patched in version 0.0.423. The vulnerability stems from how the CLI's shell safety assessment evaluates commands before execution. The safety layer pa

    • Update to 0.0.423
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →