p PatchFirst

PatchFirst · Latest vulnerabilities

@isaacs/brace-expansion vulnerabilities

Vulnerabilities published for @isaacs/brace-expansion in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerability: 1

  1. CVE-2026-25547

    Critical · CVSS 9.2EPSS 0.55%Fix available

    Uncontrolled Resource Consumption in @isaacs/brace-expansion

    @isaacs/brace-expansion is a hybrid CJS/ESM TypeScript fork of brace-expansion. Prior to version 5.0.1, @isaacs/brace-expansion is vulnerable to a denial of service (DoS) issue caused by unbounded brace range expansion. When an attacker provides a pattern containing repeated numeric brace ranges, the library attempts to eagerly generate every possible combination synchronously. Because the expansion grows exponentially, even a small input can consume excessive CPU and memory and may crash the Node.js process. This issue has been patched in version 5.0.1.

    • Update to 5.0.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →