p PatchFirst

PatchFirst · Latest vulnerabilities

bun vulnerabilities

Vulnerabilities published for bun in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 2

  1. CVE-2025-8022

    High · CVSS 8.8No fix published

    bun vulnerable to OS Command Injection

    All versions of the package bun are vulnerable to Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') in the $ shell API due to improper neutralization of user input. An attacker can exploit this by providing specially crafted input that includes command-line arguments or shell metacharacters, leading to unintended command execution.

    Published Updated
  2. CVE-2024-21548

    High · CVSS 7.7EPSS 0.67%Fix available

    CVE-2024-21548

    Versions of the package bun after 0.0.12 and before 1.1.30 are vulnerable to Prototype Pollution due to improper input sanitization. An attacker can exploit this vulnerability through Bun's APIs that accept objects. **Note:** This issue relates to the widely known and actively developed 'Bun' JavaScript runtime. The bun package on NPM at versions 0.0.12 and below belongs to a different and older project that happened to claim the 'bun' name in the past.

    • Update to 1.1.30
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →