p PatchFirst

PatchFirst · Latest vulnerabilities

compression vulnerabilities

Vulnerabilities published for compression in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerability: 1

  1. CVE-2026-87776

    High · CVSS 7.5EPSS 0.48%Fix available

    compression vulnerable to Denial of Service via memory leak on premature response close

    compression is a Node.js and Express compression middleware. In versions before 1.8.2, when a client aborts the connection while a compressed response is still being sent, the zlib stream created to compress that response is never destroyed, so each aborted compressed response leaks its native zlib memory. A remote unauthenticated attacker can repeatedly open requests and disconnect early, exhausting the available memory and crashing the server. All applications using compression are affected. The issue is fixed in compression 1.8.2, and users should upgrade to 1.8.2 or later.

    • Update to 1.8.2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →