p PatchFirst

PatchFirst · Latest vulnerabilities

elysia vulnerabilities

Vulnerabilities published for elysia in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 5

  1. CVE-2026-56669

    High · CVSS 7.5EPSS 0.63%Fix available

    Elysia: Inefficient Algorithmic Complexity and Interpretation Conflict

    Elysia is a Typescript framework for request validation, type inference, OpenAPI documentation, and client-server communication. Prior to 1.4.29, Elysia uses getAll in form data normalization for multipart/form-data endpoints, causing the amount of work to grow quadratically with the number of unique key-value pairs and allowing CPU exhaustion. This issue is fixed in version 1.4.29.

    • Update to 1.4.29
    Published Updated
  2. CVE-2026-31865

    Medium · CVSS 6.5EPSS 0.24%Fix available

    Elysia Cookie Value Prototype Pollution

    Elysia is a Typescript framework for request validation, type inference, OpenAPI documentation, and client-server communication. Prior to version 1.4.27, an Elysia cookie can be overridden by prototype pollution , eg. `__proto__`. This issue is patched in 1.4.27. As a workaround, use t.Cookie validation to enforce validation value and/or prevent iterable over cookie if possible.

    • Update to 1.4.27
    Published Updated
  3. CVE-2026-30837

    High · CVSS 7.5EPSS 0.51%Fix available

    Elysia has a string URL format redos

    Elysia is a Typescript framework for request validation, type inference, OpenAPI documentation and client-server communication. Prior to 1.4.26 , t.String({ format: 'url' }) is vulnerable to ReDoS. Repeating a partial url format (protocol and hostname) multiple times cause regex to slow down significantly. This vulnerability is fixed in 1.4.26.

    • Update to 1.4.26
    Published Updated
  4. CVE-2025-66457

    High · CVSS 7.5EPSS 0.81%Fix available

    Elysia affected by arbitrary code injection through cookie config

    Elysia is a Typescript framework for request validation, type inference, OpenAPI documentation and client-server communication. Versions 1.4.17 and below are subject to arbitrary code execution from cookie config. When dynamic cookies are enabled (e.g. there an existing cookie schema), the cookie config is injected into the compiled route without first being sanitised. Availability of this exploit is generally low, but when combined with GHSA-hxj9-33pp-j2cc, it allows for a full RCE chain. An attack requires write access to either the Elysia app's source code (in which case the vulnerability is meaningless) or write access to the cookie conf

    • Update to 1.4.18
    Published Updated
  5. CVE-2025-66456

    Critical · CVSS 9.1EPSS 0.56%Fix available

    Elysia vulnerable to prototype pollution with multiple standalone schema validation

    Elysia is a Typescript framework for request validation, type inference, OpenAPI documentation and client-server communication. Versions 1.4.0 through 1.4.16 contain a prototype pollution vulnerability in `mergeDeep` after merging results of two standard schema validations with the same key. Due to the ordering of merging, there must be an any type that is set as a standalone guard, to allow for the `__proto__ prop` to be merged. When combined with GHSA-8vch-m3f4-q8jf this allows for a full RCE by an attacker. This issue is fixed in version 1.4.17. To workaround, remove the `__proto__ key` from body.

    • Update to 1.4.17
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →