p PatchFirst

PatchFirst · Latest vulnerabilities

flowise 3.0.7: known vulnerabilities · Page 5

Known vulnerabilities affecting flowise 3.0.7: 88. Compare the fixes below with your installed release.

Filter vulnerabilities
Clear filters

Vulnerabilities: 88

  1. CVE-2026-30822

    High · CVSS 7.7EPSS 13.43%Fix available

    Flowise: Mass Assignment in `/api/v1/leads` Endpoint

    Flowise is a drag & drop user interface to build a customized large language model flow. Prior to version 3.0.13, unauthenticated users can inject arbitrary values into internal database fields when creating leads. This issue has been patched in version 3.0.13.

    • Update to 3.0.13
    Published Updated
  2. CVE-2026-30821

    High · CVSS 8.2EPSS 15.24%Fix available

    Flowise: Arbitrary File Upload via MIME Spoofing

    Flowise is a drag & drop user interface to build a customized large language model flow. Prior to version 3.0.13, the /api/v1/attachments/:chatflowId/:chatId endpoint is listed in WHITELIST_URLS, allowing unauthenticated access to the file upload API. While the server validates uploads based on the MIME types defined in chatbotConfig.fullFileUpload.allowedUploadFileTypes, it implicitly trusts the client-provided Content-Type header (file.mimetype) without verifying the file's actual content (magic bytes) or extension (file.originalname). Consequently, an attacker can bypass this restriction by spoofing the Content-Type as a permitted type (e.

    • Update to 3.0.13
    Published Updated
  3. CVE-2026-30820

    High · CVSS 8.7EPSS 0.5%Fix available

    Flowise Authorization Bypass via Spoofed x-request-from Header

    Flowise is a drag & drop user interface to build a customized large language model flow. Prior to version 3.0.13, Flowise trusts any HTTP client that sets the header x-request-from: internal, allowing an authenticated tenant session to bypass all /api/v1/** authorization checks. With only a browser cookie, a low-privilege tenant can invoke internal administration endpoints (API key management, credential stores, custom function execution, etc.), effectively escalating privilege. This issue has been patched in version 3.0.13.

    • Update to 3.0.13
    Published Updated
  4. CVE-2025-34267

    High · CVSS 8.4EPSS 6.56%Fix available

    Flowise Authenticated Command Execution and Sandbox Bypass via Puppeteer & Playwright Packages

    Flowise v3.0.1 < 3.0.8 and all versions after with 'ALLOW_BUILTIN_DEP' enabled contain an authenticated remote code execution vulnerability and node VM sandbox escape due to insecure use of integrated modules (Puppeteer and Playwright) within the nodevm execution environment. An authenticated attacker able to create or run a tool that leverages Puppeteer/Playwright can specify attacker-controlled browser binary paths and parameters. When the tool executes, the attacker-controlled executable/parameters are run on the host and circumvent the intended nodevm sandbox restrictions, resulting in execution of arbitrary code in the context of the hos

    • Update to 3.0.8
    Published Updated
  5. GHSA-j44m-5v8f-gc9c

    High · CVSS 7.7Fix available

    Flowise is vulnerable to arbitrary file exposure through its ReadFileTool

    ### Summary The ReadFileTool in Flowise does not restrict file path access, allowing authenticated attackers to exploit this vulnerability to read arbitrary files from the file system, potentially leading to remote command execution. ### Details Flowise supports providing ReadFileTool for large models to read files in the server's file system. The implementation of this tool is located at packages/components/nodes/tools/ReadFile/ReadFile.ts. ``` /** * Class for reading files from the disk. Extends the StructuredTool * class. */ export class ReadFileTool extends StructuredTool { static lc_name() { return 'ReadFileTool' }

    • Update to 3.0.8
    Published Updated
  6. CVE-2025-61913

    Critical · CVSS 10.0EPSS 13.87%Fix available

    Flowise is vulnerable to arbitrary file read, arbitrary file write

    Flowise is a drag & drop user interface to build a customized large language model flow. In versions prior to 3.0.8, WriteFileTool and ReadFileTool in Flowise do not restrict file path access, allowing authenticated attackers to exploit this vulnerability to read and write arbitrary files to any path in the file system, potentially leading to remote command execution. Flowise 3.0.8 fixes this vulnerability.

    • Update to 3.0.8
    Published Updated
  7. CVE-2025-61687

    High · CVSS 8.3EPSS 11.76%Fix available

    FlowiseAI/Flosise has File Upload vulnerability

    Flowise is a drag & drop user interface to build a customized large language model flow. A file upload vulnerability in version 3.0.7 of FlowiseAI allows authenticated users to upload arbitrary files without proper validation. This enables attackers to persistently store malicious Node.js web shells on the server, potentially leading to Remote Code Execution (RCE). The system fails to validate file extensions, MIME types, or file content during uploads. As a result, malicious scripts such as Node.js-based web shells can be uploaded and stored persistently on the server. These shells expose HTTP endpoints capable of executing arbitrary command

    • Update to 3.0.8
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →