p PatchFirst

PatchFirst · Latest vulnerabilities

mcp-markdownify-server vulnerabilities

Vulnerabilities published for mcp-markdownify-server in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 3

  1. CVE-2025-58358

    High · CVSS 7.5EPSS 0.97%Fix available

    Markdownify is vulnerable to command injection through pptx-to-markdown tool

    Markdownify is a Model Context Protocol server for converting almost anything to Markdown. Versions below 0.0.2 contain a command injection vulnerability, caused by the unsanitized use of input parameters within a call to child_process.exec, enabling an attacker to inject arbitrary system commands. Successful exploitation can lead to remote code execution under the server process's privileges. The server constructs and executes shell commands using unvalidated user input directly within command-line strings. This introduces the possibility of shell metacharacter injection (|, >, &&, etc.). This issue is fixed in version 0.0.2.

    • Update to 0.0.2
    Published Updated
  2. CVE-2025-5276

    High · CVSS 8.2EPSS 0.42%No fix published

    CVE-2025-5276

    Versions of the package mcp-markdownify-server before 1.0.0 are vulnerable to Server-Side Request Forgery (SSRF) via the Markdownify.get() function. An attacker can craft a prompt that, once accessed by the MCP host, can invoke the webpage-to-markdown, bing-search-to-markdown, and youtube-to-markdown tools to issue requests and read the responses to attacker-controlled URLs, potentially leaking sensitive information.

    Published Updated
  3. CVE-2025-5273

    High · CVSS 8.2EPSS 0.4%No fix published

    CVE-2025-5273

    Versions of the package mcp-markdownify-server before 1.0.0 are vulnerable to Files or Directories Accessible to External Parties via the get-markdown-file tool. An attacker can craft a prompt that, once accessed by the MCP host, will allow it to read arbitrary files from the host running the server.

    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →