p PatchFirst

PatchFirst · Latest vulnerabilities

mem0ai vulnerabilities

Vulnerability published for mem0ai in the last 30 days: 1. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerability: 1

  1. CVE-2026-116575

    Medium · CVSS 6.3EPSS 0.11%Fix available

    Mem0: Cross-tenant conversation leak via unescaped delimiter collision in session-scope key (_build_session_scope)

    Mem0 provides persistent memory infrastructure for AI agents and applications. Prior to Python SDK 2.0.18 and TypeScript SDK 3.1.6, _build_session_scope() in mem0/memory/main.py and Memory.buildSessionScope() in the TypeScript SDK join caller-controlled user_id, agent_id, and run_id values using unescaped & and = delimiters. A caller can embed another scope component in a controlled identifier so that distinct tenant tuples produce the same session_scope key. Memory.add(), AsyncMemory.add(), and the REST POST /memories flow use that key to read and save recent raw messages, allowing cross-tenant conversation disclosure and eviction or interle

    • Update to 3.1.6
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →